summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/noiz2sa/noiz2sa-0.51a.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/noiz2sa/noiz2sa-0.51a.ebuild')
-rw-r--r--games-action/noiz2sa/noiz2sa-0.51a.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-action/noiz2sa/noiz2sa-0.51a.ebuild b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
new file mode 100644
index 000000000000..2987086f94eb
--- /dev/null
+++ b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Abstract Shooting Game"
+HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/noiz2sa_e.html http://sourceforge.net/projects/noiz2sa/"
+SRC_URI="mirror://sourceforge/noiz2sa/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-mixer[vorbis]
+ >=dev-libs/libbulletml-0.0.3
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}/src
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ sed -i \
+ -e "s:/.noiz2sa.prf:/noiz2sa.prf:" \
+ -e "s:getenv(\"HOME\"):\"${GAMES_STATEDIR}\":" \
+ attractmanager.c \
+ || die "sed failed"
+
+ cp makefile.lin Makefile || die "Failed copying Makefile"
+}
+
+src_install(){
+ local datadir="${GAMES_DATADIR}/${PN}"
+
+ dogamesbin ${PN}
+ dodir "${datadir}" "${GAMES_STATEDIR}"
+ cp -r ../noiz2sa_share/* "${D}/${datadir}" || die "cp failed"
+ dodoc ../readme*
+ touch "${D}${GAMES_STATEDIR}/${PN}.prf"
+ fperms 660 "${GAMES_STATEDIR}/${PN}.prf"
+ prepgamesdirs
+}