summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/abuse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/abuse')
-rw-r--r--games-action/abuse/Manifest1
-rw-r--r--games-action/abuse/abuse-0.8.ebuild46
-rw-r--r--games-action/abuse/files/abuse-0.8-gentoo.patch24
-rw-r--r--games-action/abuse/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/games-action/abuse/Manifest b/games-action/abuse/Manifest
new file mode 100644
index 000000000000..5cf67eb4b301
--- /dev/null
+++ b/games-action/abuse/Manifest
@@ -0,0 +1 @@
+DIST abuse-0.8.tar.gz 6053500 SHA256 0104db5fd2695c9518583783f7aaa7e5c0355e27c5a803840a05aef97f9d3488 SHA512 5c60dcf6910f9f751da26e919cd289c12349bb82eb925f9a41dc921263ece0d0f5f24c2ab2d1c718c0a5d0315453f92dfcba665fe5082eb4135ed737d2859d18 WHIRLPOOL f33cc8f2238e59e4aa6b8387987859baada02f292cbfc45c451eb1d0db41c36f2548cb2d9e527c5437957aacd3062680b6e7c32082788cedd15e78b4963f9b5e
diff --git a/games-action/abuse/abuse-0.8.ebuild b/games-action/abuse/abuse-0.8.ebuild
new file mode 100644
index 000000000000..10f8166b689f
--- /dev/null
+++ b/games-action/abuse/abuse-0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils games
+
+DESCRIPTION="port of Abuse by Crack Dot Com"
+HOMEPAGE="http://abuse.zoy.org/"
+SRC_URI="http://abuse.zoy.org/raw-attachment/wiki/download/${P}.tar.gz"
+
+LICENSE="GPL-2 WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.6[sound,opengl,video]
+ media-libs/sdl-mixer
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-assetdir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ # Source-based install
+ default
+
+ doicon doc/${PN}.png
+ make_desktop_entry abuse Abuse
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "NOTE: If you had previous version of abuse installed"
+ elog "you may need to remove ~/.abuse for the game to work correctly."
+}
diff --git a/games-action/abuse/files/abuse-0.8-gentoo.patch b/games-action/abuse/files/abuse-0.8-gentoo.patch
new file mode 100644
index 000000000000..c5d97834d9ec
--- /dev/null
+++ b/games-action/abuse/files/abuse-0.8-gentoo.patch
@@ -0,0 +1,24 @@
+diff -ru abuse-0.8.orig/Makefile.am abuse-0.8/Makefile.am
+--- abuse-0.8.orig/Makefile.am 2011-05-09 03:58:04.000000000 -0400
++++ abuse-0.8/Makefile.am 2011-05-16 22:22:51.642655295 -0400
+@@ -2,8 +2,6 @@
+
+ SUBDIRS = src data doc
+
+-EXTRA_DIST = COPYING.GPL COPYING.WTFPL PACKAGERS bootstrap
+-
+ dist-hook:
+ @echo ""
+ @echo " ===================================================="
+diff -ru abuse-0.8.orig/configure.ac abuse-0.8/configure.ac
+--- abuse-0.8.orig/configure.ac 2011-05-09 03:58:04.000000000 -0400
++++ abuse-0.8/configure.ac 2011-05-16 22:22:35.771824632 -0400
+@@ -90,8 +90,6 @@
+ fi
+ AM_CONDITIONAL(HAVE_NONFREE, test "${ac_cv_have_nonfree}" = "yes")
+
+-# Optimizations
+-CXXFLAGS="${CXXFLAGS} ${OPT} ${REL}"
+ # Code qui fait des warnings == code de porc == deux baffes dans ta gueule
+ CXXFLAGS="${CXXFLAGS} -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wsign-compare"
+
diff --git a/games-action/abuse/metadata.xml b/games-action/abuse/metadata.xml
new file mode 100644
index 000000000000..f72870c0c28d
--- /dev/null
+++ b/games-action/abuse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>