summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-03 13:15:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-03 13:18:29 +0200
commit9f9cb6384282d814e68022fe2ab03445ab1b7d32 (patch)
tree7af0ef03001bacb0c3418ad41176cf3250b115f8 /dev-util
parentnet-libs/gsoap: Fix LICENSE. (diff)
downloadgentoo-9f9cb6384282d814e68022fe2ab03445ab1b7d32.tar.gz
gentoo-9f9cb6384282d814e68022fe2ab03445ab1b7d32.tar.bz2
gentoo-9f9cb6384282d814e68022fe2ab03445ab1b7d32.zip
dev-util/cvise: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cvise/Manifest1
-rw-r--r--dev-util/cvise/cvise-1.6.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/cvise/Manifest b/dev-util/cvise/Manifest
index d2add3abf8e5..7f952238977a 100644
--- a/dev-util/cvise/Manifest
+++ b/dev-util/cvise/Manifest
@@ -1 +1,2 @@
DIST cvise-1.1.0.tar.gz 228867 BLAKE2B 08becb5ad00ef08a1f511c0bdb0cb649af1406dd035fe61f737ec6dfb5151215ae363272fc3676ce76e17234a88866ee1dd0664d82326f3ddb2ced2f1982aacf SHA512 66c09cb7e088fc36b0c36928e2eda19e7bef4fad4573fcedc06f2070136e74d7878f8056f406c2ade22fc465a75bf13dca9f4a1a319cd183187a2d66a441e661
+DIST cvise-1.6.0.tar.gz 243050 BLAKE2B 64c305426dbeaf2e3f3a92a902209b35fcc76b5f5a6d2e48fcc8e24d1325badc0839e70afa1381c6d1412c22a7e9dd41ca03d6ca714fa5082958378cc8863000 SHA512 9d4ee043c34748b600b49ac4f00463b853faff2809f8b581e9b07433a8f3bef4436d0e5d5a9dbff1b2d7c3a8ab1d6d4823e78787eb3e911a683808703b2e24b6
diff --git a/dev-util/cvise/cvise-1.6.0.ebuild b/dev-util/cvise/cvise-1.6.0.ebuild
new file mode 100644
index 000000000000..819ee2f921ed
--- /dev/null
+++ b/dev-util/cvise/cvise-1.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+: ${CMAKE_MAKEFILE_GENERATOR=ninja}
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake llvm python-single-r1
+
+DESCRIPTION="Super-parallel Python port of the C-Reduce"
+HOMEPAGE="https://github.com/marxin/cvise/"
+SRC_URI="
+ https://github.com/marxin/cvise/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+LLVM_MAX_SLOT=12
+DEPEND="
+ || (
+ sys-devel/clang:12
+ sys-devel/clang:11
+ sys-devel/clang:10
+ )
+ <=sys-devel/clang-$(( LLVM_MAX_SLOT + 1 )):="
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pebble[${PYTHON_USEDEP}]
+ ')
+ dev-util/unifdef
+ sys-devel/flex"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/flex
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )"
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ llvm_pkg_setup
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ pytest -vv || die
+}