summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2019-06-08 00:32:36 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-15 16:19:17 +0200
commit9cfb9d99622ed21335980d7999af5b143feab5ed (patch)
tree256106da7534b989580382f9a7d1676cf47da3c6 /dev-util
parentdev-util/scons: 3.0.5-r1 repair src_unpack() to fix Docbook tests (diff)
downloadgentoo-9cfb9d99622ed21335980d7999af5b143feab5ed.tar.gz
gentoo-9cfb9d99622ed21335980d7999af5b143feab5ed.tar.bz2
gentoo-9cfb9d99622ed21335980d7999af5b143feab5ed.zip
dev-util/scons: 3.0.5-r1 fix passthrough of $PATH env
The env-passthrough patch make possible to pass $PATH env to scons build env while build of packages that use scons as build system by call of escons() function from scons-util.eclass. The escons() func. setup GENTOO_SCONS_ENV_PASSTHROUGH=1 variable that make the patch mentioned above to be working. The scons package doesn't call escons() so it get to setup GENTOO_ENV_PASSTHROUTH=1 variable directly within python_test() phase. This fix repairs Clang tests that failed because the clang and clang++ couldn't be found within scons test env. Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scons/scons-3.0.5-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-util/scons/scons-3.0.5-r1.ebuild b/dev-util/scons/scons-3.0.5-r1.ebuild
index 5dba6c1f8dab..e7f2ac66479c 100644
--- a/dev-util/scons/scons-3.0.5-r1.ebuild
+++ b/dev-util/scons/scons-3.0.5-r1.ebuild
@@ -62,6 +62,8 @@ src_prepare() {
}
python_test() {
+ # set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
+ local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
cd "${WORKDIR}/${P}" || die
"${EPYTHON}" runtest.py -a --passed \
-j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \