summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-09-14 12:53:39 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-09-15 10:41:11 -0700
commit5999e97547e8a25853c81d07afb052551cf2ffb4 (patch)
treec90ee2fc35d4beebc1b4cf0d98134f0805c412b5 /dev-util
parentdev-util/buildbot-console-view: Version bump, fix metadata.xml indentation (diff)
downloadgentoo-5999e97547e8a25853c81d07afb052551cf2ffb4.tar.gz
gentoo-5999e97547e8a25853c81d07afb052551cf2ffb4.tar.bz2
gentoo-5999e97547e8a25853c81d07afb052551cf2ffb4.zip
dev-util/buildbot-pkg: Version bump, fix metadata.xml indentation
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.11.ebuild45
-rw-r--r--dev-util/buildbot-pkg/metadata.xml35
3 files changed, 64 insertions, 17 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index a635f9e2d0a6..cee2b696feed 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -1,4 +1,5 @@
DIST buildbot-pkg-0.9.10.tar.gz 4422 SHA256 6eecdde02f98be469ec9fde47c55fe64ca04eec764a4729be2ff4faa892532d8 SHA512 d31ef269ddbd042a9064daea526f289f2ec3ffa58dc8f43a8e40ae81b03cfa026f219bcce2ccb83addca0b1da0a8a2d3bc894a400edb9c45f4c0cde7691b5e4d WHIRLPOOL 36ff1465b3f0ab2699d3c9b5916862b1f3038e4fa999939730a7a280576b2bae5f106d2f34faabfe6ae3cabfe4ea5bcfd75bb472dddc6ac43fc36ad702d81aed
+DIST buildbot-pkg-0.9.11.tar.gz 4420 SHA256 6328abfa68efba299d0309a88b8de40d71d1da4d7bc9148476fed8f393e407be SHA512 63f75f4df2a725caa48d98c09037580c7b6a16609e4063e7aaab8a0e4b7bda4c74da8bf524b7d9a0cf9e909146522af5ffe8f1a5a8617c5f67658cc723f61b2e WHIRLPOOL 795aeeb945191bcd23df5acec634c2782e7910f9c10cbc9d7586d01baea82034d33273c98708676344adba67d0a8a9a29d3c6b37ea45d055e1b737b19189e869
DIST buildbot-pkg-0.9.4.tar.gz 3830 SHA256 968f252f0700fbbcc6cac9f3fcf66d06bd577db5bf793fb3d7c84158f4f64325 SHA512 ac41792076e5a86ffeb58e694d6aedcf3cf386facf156ce658dfa7c73166c7883c097d160babf6d6ca92c1fba1527db58bade74c3500fb62c448eeecbd840dc0 WHIRLPOOL cb4255c90ae59750aa43fea890d79880bb30958ca36ee27a0f11e859575372dbee82708960dd8862c1ac551b4f9e5b38e4d70c8b7cc87048385c08c31ed455c3
DIST buildbot-pkg-0.9.7.tar.gz 3871 SHA256 fbb75cff1d313a0fa810894073716ddf56b834ede761b1fae34f100f420e655c SHA512 7991425e69a404e15fd018d920accc65915e9d40a3b4b1faeca7b7501d1c9a2b01c2bef209ac10b9ea4dce03a41fd0d05266a5c3c9d50ec0f936a5f1c80f577b WHIRLPOOL 186fe1d1f155df98452e441303f916c498a01fc1e01ce741388ca00f33dd83105aad59d3024fd5b2f50680369f99e17fa609c3d325f291f4a33df7699d8394e5
DIST buildbot-pkg-0.9.8.tar.gz 3913 SHA256 10000b0630d2f96230fada97828b986b4e9f4897fefb4b8be63e51b73e6ed63c SHA512 53e21a4ed20df687f9f646f0570fe610bd6d9da116bf7fdd60f1f2d245541ba9444e6cf7c63e3d780979a9320c9b98fcbe310acd736e3877c02bee31c683ebfc WHIRLPOOL 831f21235e4396603e4fdaec226006a7c6e01fd8378c7df9c2a8a24724542c315f97641b9fe4edb353405b79273bd361e7dade34a2be81be9e27c551728351ee
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.11.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.11.ebuild
new file mode 100644
index 000000000000..dd96a049c7cf
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-pkg"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/buildbot-pkg/metadata.xml b/dev-util/buildbot-pkg/metadata.xml
index 00d0bf0e6bb5..0661cac6ea60 100644
--- a/dev-util/buildbot-pkg/metadata.xml
+++ b/dev-util/buildbot-pkg/metadata.xml
@@ -2,26 +2,27 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>hwoarang@gentoo.org</email>
- <name>Markos Chandras</name>
- </maintainer>
- <maintainer type="person">
<email>dolsen@gentoo.org</email>
<name>Brian Dolbec</name>
</maintainer>
- <longdescription lang="en">The BuildBot is a system to automate the compile/test cycle required
- by most software projects to validate code changes.
- Features:
- * run builds on a variety of slave platforms
- * arbitrary build process: handles projects using C, Python, whatever
- * minimal host requirements: python and Twisted
- * slaves can be behind a firewall if they can still do checkout
- * status delivery through web page, email, IRC, other protocols
- * track builds in progress, provide estimated completion time
- * flexible configuration by subclassing generic build process classes
- * debug tools to force a new build, submit fake Changes, query slave
- status
- * released under the GPL</longdescription>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+ BuildBot is a system to automate the compile/test cycle required
+ by most software projects to validate code changes.
+ Features:
+ * run builds on a variety of slave platforms
+ * arbitrary build process: handles projects using C, Python, whatever
+ * minimal host requirements: python and Twisted
+ * slaves can be behind a firewall if they can still do checkout
+ * status delivery through web page, email, IRC, other protocols
+ * track builds in progress, provide estimated completion time
+ * flexible configuration by subclassing generic build process classes
+ * debug tools to force a new build, submit fake Changes, query slave status
+ * released under the GPL
+ </longdescription>
<upstream>
<maintainer>
<email>devel@buildbot.net</email>