summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-13 03:03:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-13 03:19:59 -0400
commitdde8c3f4bdcec2a7435f88a047615991bc474d04 (patch)
tree000fc76faf49ba032940ab3a39c72aa0b0a9d5d1 /dev-util/mingw64-toolchain
parentmedia-libs/libshout: Stabilize 2.4.6 sparc, #844004 (diff)
downloadgentoo-dde8c3f4bdcec2a7435f88a047615991bc474d04.tar.gz
gentoo-dde8c3f4bdcec2a7435f88a047615991bc474d04.tar.bz2
gentoo-dde8c3f4bdcec2a7435f88a047615991bc474d04.zip
dev-util/mingw64-toolchain: fix direct objdump call
Cherry pick from Gentoo's gcc patches. Ideally don't want to carry/follow the full set given they do not really affect this (features are disabled, or irrelevant with mingw target), but this one does. Turns out plugin is silently skipped entirely if objdump is missing. Bug: https://bugs.gentoo.org/843989 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch22
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch b/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch
new file mode 100644
index 000000000000..1de712de48bc
--- /dev/null
+++ b/dev-util/mingw64-toolchain/files/gcc-11.3.0-plugin-objdump.patch
@@ -0,0 +1,22 @@
+https://gcc.gnu.org/PR95648
+--- a/gcc/config/gcc-plugin.m4
++++ b/gcc/config/gcc-plugin.m4
+@@ -47,3 +47,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
+--- a/gcc/gcc/configure
++++ b/gcc/gcc/configure
+@@ -32069,3 +32069,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
+--- a/gcc/libcc1/configure
++++ b/gcc/libcc1/configure
+@@ -15017,3 +15017,3 @@
+ if test x$build = x$host; then
+- export_sym_check="objdump${exeext} -T"
++ export_sym_check="$ac_cv_prog_OBJDUMP -T"
+ elif test x$host = x$target; then
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
index 4df5573bc1e4..13b92a3c573c 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/mingw64-runtime-10.0.0-tmp-files-clash.patch
+ "${FILESDIR}"/gcc-11.3.0-plugin-objdump.patch
)
pkg_pretend() {