summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2021-11-29 14:47:39 -0800
committerSam James <sam@gentoo.org>2021-12-05 03:52:50 +0000
commit6608f92a76237bedab022c62bef7cf157e2b28a6 (patch)
tree3380a7826587a15e208b2a8745f632a5ed1d92ed /dev-util/maxcso/maxcso-1.13.0.ebuild
parentdev-perl/Test-Warnings: Stabilize 0.31.0 arm64, #828215 (diff)
downloadgentoo-6608f92a76237bedab022c62bef7cf157e2b28a6.tar.gz
gentoo-6608f92a76237bedab022c62bef7cf157e2b28a6.tar.bz2
gentoo-6608f92a76237bedab022c62bef7cf157e2b28a6.zip
dev-util/maxcso: New package
Closes: https://github.com/gentoo/gentoo/pull/23119 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/maxcso/maxcso-1.13.0.ebuild')
-rw-r--r--dev-util/maxcso/maxcso-1.13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/maxcso/maxcso-1.13.0.ebuild b/dev-util/maxcso/maxcso-1.13.0.ebuild
new file mode 100644
index 000000000000..a9f29908ada6
--- /dev/null
+++ b/dev-util/maxcso/maxcso-1.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Fast cso compressor"
+HOMEPAGE="https://github.com/unknownbrackets/maxcso"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/unknownbrackets/maxcso.git"
+else
+ SRC_URI="https://github.com/unknownbrackets/maxcso/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC MIT LGPL-2.1+ Apache-2.0"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ app-arch/lz4
+ dev-libs/libuv
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.md README_CSO.md README_ZSO.md
+}