summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/indent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/indent')
-rw-r--r--dev-util/indent/Manifest1
-rw-r--r--dev-util/indent/files/2.2.11-segfault.patch16
-rw-r--r--dev-util/indent/files/2.2.11-texi2html-5.patch40
-rw-r--r--dev-util/indent/indent-2.2.11-r1.ebuild61
-rw-r--r--dev-util/indent/metadata.xml12
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-util/indent/Manifest b/dev-util/indent/Manifest
new file mode 100644
index 000000000000..ccd97acc323d
--- /dev/null
+++ b/dev-util/indent/Manifest
@@ -0,0 +1 @@
+DIST indent-2.2.11.tar.gz 778563 SHA256 aaff60ce4d255efb985f0eb78cca4d1ad766c6e051666073050656b6753a0893 SHA512 f5670e5edc76b9d599ef9e8cc498e13ac15e10eb6a8d674e1612918c4b67ffb15c94d73b9590434e0cdea6ead4b8d1f5bcda1c2f3838acbdeb4d732a0bea89be WHIRLPOOL b50d6af34af8e08febde01fc70a280e8fdce0eb25b2e7e23f9d20bf08afc055c98b01c28f971c05bf4f8f52d9a70af10265329b5e146b2c6e64481aecb9fb8ad
diff --git a/dev-util/indent/files/2.2.11-segfault.patch b/dev-util/indent/files/2.2.11-segfault.patch
new file mode 100644
index 000000000000..e91922480951
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-segfault.patch
@@ -0,0 +1,16 @@
+--- a/man/texinfo2man.c
++++ b/man/texinfo2man.c
+@@ -287,6 +287,13 @@
+ char buf[1024];
+ int line_no = 0;
+
++ if (argc != 3)
++ {
++ fprintf(stderr, "Usage: %s <man template> <info file>\n", argv[0]);
++ fprintf(stderr, " The man page will be written to stdout.\n");
++ return -1;
++ }
++
+ texinfoname = argv[2];
+
+ in = fopen (argv[2], "r");
diff --git a/dev-util/indent/files/2.2.11-texi2html-5.patch b/dev-util/indent/files/2.2.11-texi2html-5.patch
new file mode 100644
index 000000000000..5bad3da2867b
--- /dev/null
+++ b/dev-util/indent/files/2.2.11-texi2html-5.patch
@@ -0,0 +1,40 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -34,14 +34,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -663,14 +663,14 @@
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html
diff --git a/dev-util/indent/indent-2.2.11-r1.ebuild b/dev-util/indent/indent-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..6964ee06a46c
--- /dev/null
+++ b/dev-util/indent/indent-2.2.11-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="http://indent.isidore-it.eu/beautify.html http://www.gnu.org/software/indent/"
+SRC_URI="http://${PN}.isidore-it.eu/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+ app-text/texi2html
+"
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+
+INDENT_LINGUAS="
+ ca da de eo et fi fr gl hu it ja ko nl pl pt_BR ru sk sv tr zh_TW
+"
+
+for indent_lingua in ${INDENT_LINGUAS}; do
+ IUSE+=" linguas_${indent_lingua}"
+done
+
+src_prepare() {
+ # Fix bug #94837
+ local pofile
+ for pofile in po/zh_TW*; do
+ mv ${pofile} ${pofile/.Big5} || die
+ done
+ sed -i po/LINGUAS -e 's|zh_TW\.Big5|zh_TW|g' || die
+
+ epatch \
+ "${FILESDIR}"/${PV}-segfault.patch \
+ "${FILESDIR}"/${PV}-texi2html-5.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautomake
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_test() {
+ emake -C regression/
+}
+
+src_install() {
+ # htmldir as set in configure is ignored in doc/Makefile*
+ emake DESTDIR="${D}" htmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS NEWS README ChangeLog ChangeLog-1990 ChangeLog-1998 ChangeLog-2001
+}
diff --git a/dev-util/indent/metadata.xml b/dev-util/indent/metadata.xml
new file mode 100644
index 000000000000..c472d21a01a0
--- /dev/null
+++ b/dev-util/indent/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
+<longdescription lang="en">
+Indent is the GNU indenting program. It is used to beautify C program source
+files.
+</longdescription>
+</pkgmetadata>