summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-03-28 20:31:43 +0200
committerWilliam Hubbs <williamh@gentoo.org>2022-03-28 21:37:41 -0500
commitcfed4d10bd3144ed782b625e266cedd533d505d6 (patch)
treea000bc6ebf10099a0377e6f78d24edc68e0236ea /dev-util/gitlab-runner
parentdev-python/black: add 22.3.0 (diff)
downloadgentoo-cfed4d10bd3144ed782b625e266cedd533d505d6.tar.gz
gentoo-cfed4d10bd3144ed782b625e266cedd533d505d6.tar.bz2
gentoo-cfed4d10bd3144ed782b625e266cedd533d505d6.zip
dev-util/gitlab-runner: fix init script syntax
Closes: https://bugs.gentoo.org/836305 Closes: https://github.com/gentoo/gentoo/pull/24795 Thanks-to: Henning Schild <henning@hennsch.de> Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/files/gitlab-runner.initd11
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-14.9.1-r1.ebuild (renamed from dev-util/gitlab-runner/gitlab-runner-14.9.1.ebuild)0
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/gitlab-runner/files/gitlab-runner.initd b/dev-util/gitlab-runner/files/gitlab-runner.initd
index 8ae45b510fd0..0e5c5ed224b6 100644
--- a/dev-util/gitlab-runner/files/gitlab-runner.initd
+++ b/dev-util/gitlab-runner/files/gitlab-runner.initd
@@ -1,20 +1,23 @@
#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
command="/usr/bin/gitlab-runner"
+runner_datadir="${runner_datadir:-/var/lib/gitlab-runner}"
command_args="run
--config ${runner_config:-/etc/gitlab-runner/config.toml}
--service ${runner_service:-${RC_SVCNAME}}
--user ${runner_user:-gitlab-runner}
- --working-directory ${runner_datadir:-/var/lib/gitlab-runner}
+ --working-directory ${runner_datadir}
${RUNNER_OPTS}"
command_background=true
extra_started_commands="reload"
name="${name:-GitLab Runner}"
pidfile="/run/${RC_SVCNAME}.pid"
-output_log="${output_log:-${runner_logdir}/gitlab-runner.log"
-error_log="${error_log:-${runner_logdir}/gitlab-runner.err"
+runner_user="${runner_user:-gitlab-runner}"
+runner_logdir="${runner_logdir:-/var/log/gitlab-runner}"
+output_log="${output_log:-${runner_logdir}/gitlab-runner.log}"
+error_log="${error_log:-${runner_logdir}/gitlab-runner.err}"
retry="QUIT/60/TERM/60"
required_files="${runner_config}"
diff --git a/dev-util/gitlab-runner/gitlab-runner-14.9.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-14.9.1-r1.ebuild
index 22780481d840..22780481d840 100644
--- a/dev-util/gitlab-runner/gitlab-runner-14.9.1.ebuild
+++ b/dev-util/gitlab-runner/gitlab-runner-14.9.1-r1.ebuild