summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-28 07:44:53 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-28 07:52:05 +0200
commitb32023a27514e51957187da5f9b2de518a697cfc (patch)
treefdc2e1e4065baeb256d15bd6f0d3cf5b9a9951f5 /dev-util/debugedit
parentdev-ruby/ruby2ruby: add 2.4.4 (diff)
downloadgentoo-b32023a27514e51957187da5f9b2de518a697cfc.tar.gz
gentoo-b32023a27514e51957187da5f9b2de518a697cfc.tar.bz2
gentoo-b32023a27514e51957187da5f9b2de518a697cfc.zip
dev-util/debugedit: Bump to 4.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/Manifest1
-rw-r--r--dev-util/debugedit/debugedit-4.15.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index 355633f1484d..4c309b616055 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -1 +1,2 @@
DIST rpm-4.14.2.tar.bz2 4151934 BLAKE2B eb7e32dd736a195f2e5effc184ee8f2c700dcaf80477574c2112b6c96504d86a67c81e611f82ea35ce244e95fad339bd262eb51c35ada5eeffa8d306b6938cb7 SHA512 22e309e8be936e6070430cedd6f5ea0c3871db4c6aadd0d567a9c418796c178c8dd45d44920d7eaa66681790cc2821347affe471cb215d7a490fe7947fbf291c
+DIST rpm-4.15.0.tar.bz2 4205632 BLAKE2B 3e9701582e82d4164a21374df78c7a9ab3ca4f9aeafc13706fd0aa27782a34d2a732d7ae9659589abc9f9b8a48ce5c2cdbbea72c46768f1baba28ded26817e5b SHA512 bca9cc9ef0ad53fa5cd257c29a0a0b9447956afe4024835f5416b13926bc8bbaf8aacd481e721b4a28983bc57f98b75b91750d39dd72de4876efa9d6db53a26c
diff --git a/dev-util/debugedit/debugedit-4.15.0.ebuild b/dev-util/debugedit/debugedit-4.15.0.ebuild
new file mode 100644
index 000000000000..7a6ec67dddc6
--- /dev/null
+++ b/dev-util/debugedit/debugedit-4.15.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=rpm-${PV}
+DESCRIPTION="Stand-alone debugedit from RPM"
+HOMEPAGE="https://rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib:=
+ >=dev-libs/popt-1.7
+ >=dev-libs/elfutils-0.176-r1
+ dev-libs/nss
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply_user
+
+ # cheat it into believing we're bundling db
+ mkdir -p db/dist || die
+ touch db/dist/configure || die
+ chmod +x db/dist/configure || die
+ echo 'install:' > db3/Makefile || die
+
+ # TODO: why do we need to do this?
+ mkdir rpm || die
+ find -name '*.h' -exec cp {} rpm/ ';' || die
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ local myconf=(
+ # force linking to static librpmio
+ --disable-shared
+
+ # disable linking compression libraries
+ ac_cv_header_bzlib_h=no
+ ac_cv_header_lzma_h=no
+ --disable-zstd
+
+ # fake some libraries we don't use
+ ac_cv_header_magic_h=yes
+ ac_cv_lib_magic_magic_open=yes
+
+ # use nss as crypto provider
+ --with-crypto=nss
+
+ # disable other stuff irrelevant to debugedit
+ --disable-bdb
+ --disable-nls
+ --disable-plugins
+ --disable-python
+ --without-acl
+ --without-archive
+ --without-cap
+ --without-external-db
+ --without-hackingdocs
+ --without-lua
+ --without-selinux
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -C misc
+ emake -C rpmio
+ emake debugedit
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ dobin debugedit
+}