summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-26 10:20:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-26 17:48:38 +0100
commitc6ebedbe1bcf3d9c953a1795fe1b20c7cc655cc1 (patch)
tree7e3e1091ba7d938ee053231307e0afbd2c41156d /dev-util/catfish
parentdev-libs/hiredis: fix deletion of static libs (diff)
downloadgentoo-c6ebedbe1bcf3d9c953a1795fe1b20c7cc655cc1.tar.gz
gentoo-c6ebedbe1bcf3d9c953a1795fe1b20c7cc655cc1.tar.bz2
gentoo-c6ebedbe1bcf3d9c953a1795fe1b20c7cc655cc1.zip
dev-util/catfish: Bump to 4.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.15.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index efdc9cb7b776..9633f52d4361 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1 +1,2 @@
DIST catfish-1.4.13.tar.bz2 221999 BLAKE2B b487947954832c691a5a1b3bd2a49e7ae1aedecbe2084b86b9ae1c8bd7c95f6d3746f80723d351bed3abac0e2396fcce134072345a908f5ba9f0dfebdd95108f SHA512 a90c695e7c1a2172ea7a5f7f1a292e95aa290693a24f3988a68f2fb4597183ff7526c98925fb3ef8517fbca508a1c3853e0de87ec023be9424d994d63e29c886
+DIST catfish-4.15.0.tar.bz2 256897 BLAKE2B 98ac6c1f5af7a48276438c08e0259eaae7f9a7d4f043a8c89b945d1d0a18e10f2faf3a210363cf46a97b4becc7492a6c1ce6b8e499b168729ce18ff80d5da828 SHA512 d2415194e3d803a99b1a0d80763db6f4e95c810d2bc679057e54105bb906ec1a0de32b64d8c0b2a36aad11d689401111c3466b1e8ad41760f4d6b67f979a81a3
diff --git a/dev-util/catfish/catfish-4.15.0.ebuild b/dev-util/catfish/catfish-4.15.0.ebuild
new file mode 100644
index 000000000000..123c750a72e2
--- /dev/null
+++ b/dev-util/catfish/catfish-4.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}