summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-09-14 12:56:13 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-09-15 10:41:12 -0700
commit36e25a2809f96edd3fa2c6f93951eab85e5ea18c (patch)
tree36de17d50f5b116f0994fc365eaf476092ddf8e8 /dev-util/buildbot-www/buildbot-www-0.9.11.ebuild
parentdev-util/buildbot-pkg: Version bump, fix metadata.xml indentation (diff)
downloadgentoo-36e25a2809f96edd3fa2c6f93951eab85e5ea18c.tar.gz
gentoo-36e25a2809f96edd3fa2c6f93951eab85e5ea18c.tar.bz2
gentoo-36e25a2809f96edd3fa2c6f93951eab85e5ea18c.zip
dev-util/buildbot-www: Version bump, fix metadata.xml indentation
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-0.9.11.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-0.9.11.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-0.9.11.ebuild b/dev-util/buildbot-www/buildbot-www-0.9.11.ebuild
new file mode 100644
index 000000000000..e248b15e6f78
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-0.9.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-www"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}