summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-10-29 21:39:28 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-10-29 21:39:47 +0100
commit891282ee23ea491f4212b9b4ccb95a807205af99 (patch)
tree41f3a2d79a3be4b0f85e3f93663f711f762ce850 /dev-util/breakpad
parentdev-python/structlog: Stabilize 23.2.0 arm, #916444 (diff)
downloadgentoo-891282ee23ea491f4212b9b4ccb95a807205af99.tar.gz
gentoo-891282ee23ea491f4212b9b4ccb95a807205af99.tar.bz2
gentoo-891282ee23ea491f4212b9b4ccb95a807205af99.zip
dev-util/breakpad: add 2023.01.27
Closes: https://bugs.gentoo.org/916215 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-util/breakpad')
-rw-r--r--dev-util/breakpad/Manifest1
-rw-r--r--dev-util/breakpad/breakpad-2023.01.27.ebuild55
-rw-r--r--dev-util/breakpad/files/breakpad-2023.01.27-gentoo.patch119
3 files changed, 175 insertions, 0 deletions
diff --git a/dev-util/breakpad/Manifest b/dev-util/breakpad/Manifest
index b17d5765b09e..71ea12e876ac 100644
--- a/dev-util/breakpad/Manifest
+++ b/dev-util/breakpad/Manifest
@@ -1 +1,2 @@
DIST breakpad-2022.07.12.tar.gz 5373070 BLAKE2B 3598bcebf249c73a13eb77743ee993fb96ebf9585a68e45169afcf34fb836a126ce3b8d71e78dedd3407b843297857619de39fc38661ff80545d572dde098ea1 SHA512 872fa74520709d6510b798c7adfb7fed34a84b1831e774087515c23a005b0ea76ef7758bb565f0ff9f2153206cf53958621463fba0e055c9d31dc68f687e2b8f
+DIST breakpad-2023.01.27.tar.gz 5455242 BLAKE2B 650f9c2ff4ee5e50f9d51573706757cc56a4d64171a5aea7b825327c55b05b9122d375e718951eee26c2bde7aae69d385205fa777fa23e61e5c97683f3c76120 SHA512 c6802c55653289780232b20e2abc0458c49f3cdff108c3ddfd6e40a2f378da34adbc158548e9c88cbfdbba9526477da9b68c2c45e205231e2802fe533b6bd6a4
diff --git a/dev-util/breakpad/breakpad-2023.01.27.ebuild b/dev-util/breakpad/breakpad-2023.01.27.ebuild
new file mode 100644
index 000000000000..398f79e86f23
--- /dev/null
+++ b/dev-util/breakpad/breakpad-2023.01.27.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="implement a crash-reporting system."
+HOMEPAGE="https://chromium.googlesource.com/breakpad/breakpad/"
+SRC_URI="https://github.com/google/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-4"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ dev-libs/linux-syscall-support
+ dev-embedded/libdisasm
+"
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|"third_party/lss\(.*\)"|<lss\1>|' \
+ $(find src -name '*.cc' -o -name '*.h') \
+ || die
+ sed -i \
+ -e '/includelss/d' \
+ -e '/third_party\/curl/d' \
+ Makefile.am \
+ || die
+ sed -i \
+ -e "/AC_INIT/s:0.1:${PVR}:" \
+ -e "/AS_VAR_APPEND/d" \
+ configure.ac \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-system-test-libs \
+ || die
+}
diff --git a/dev-util/breakpad/files/breakpad-2023.01.27-gentoo.patch b/dev-util/breakpad/files/breakpad-2023.01.27-gentoo.patch
new file mode 100644
index 000000000000..83a4e824c970
--- /dev/null
+++ b/dev-util/breakpad/files/breakpad-2023.01.27-gentoo.patch
@@ -0,0 +1,119 @@
+--- a/src/common/linux/libcurl_wrapper.h 2022-06-07 21:55:00.387396660 +0200
++++ b/src/common/linux/libcurl_wrapper.h 2022-06-07 21:55:18.450145751 +0200
+@@ -36,7 +36,7 @@
+ #include <map>
+
+ #include "common/using_std_string.h"
+-#include "third_party/curl/curl.h"
++#include <curl/curl.h>
+
+ namespace google_breakpad {
+
+--- a/src/common/linux/http_upload.cc 2022-06-07 21:53:55.505298529 +0200
++++ b/src/common/linux/http_upload.cc 2022-06-07 21:54:17.944986506 +0200
+@@ -30,7 +30,7 @@
+
+ #include <assert.h>
+ #include <dlfcn.h>
+-#include "third_party/curl/curl.h"
++#include <curl/curl.h>
+
+ namespace {
+
+--- a/src/processor/disassembler_x86.h 2022-06-08 08:41:45.569686249 +0200
++++ b/src/processor/disassembler_x86.h 2022-06-08 08:42:09.049377873 +0200
+@@ -42,7 +42,7 @@
+ #include "google_breakpad/common/breakpad_types.h"
+
+ namespace libdis {
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+ }
+
+ namespace google_breakpad {
+--- a/Makefile.am 2022-06-08 08:51:35.221948155 +0200
++++ b/Makefile.am 2022-06-08 08:53:21.679551745 +0200
+@@ -176,7 +176,6 @@
+
+ lib_LIBRARIES += src/libbreakpad.a
+ pkgconfig_DATA += breakpad.pc
+-noinst_LIBRARIES += src/third_party/libdisasm/libdisasm.a
+
+ ## Programs
+ bin_PROGRAMS += \
+@@ -944,7 +943,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -967,7 +966,7 @@
+ $(AM_CPPFLAGS) $(TEST_CFLAGS)
+ src_processor_disassembler_x86_unittest_LDADD = \
+ src/processor/disassembler_x86.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -1074,7 +1073,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -1104,7 +1103,7 @@
+ src_processor_proc_maps_linux_unittest_LDADD = \
+ src/processor/logging.o \
+ src/processor/pathname_stripper.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -1405,7 +1404,7 @@
+ src/processor/stackwalker_sparc.o \
+ src/processor/stackwalker_x86.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a
++ -ldisasm
+
+ src_processor_minidump_stackwalk_SOURCES = \
+ src/processor/minidump_stackwalk.cc
+@@ -1448,7 +1448,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a
++ -ldisasm
+
+ ## Additional files to be included in a source distribution
+ ##
+--- a/src/processor/exploitability_win.cc 2022-06-08 08:59:44.437471336 +0200
++++ b/src/processor/exploitability_win.cc 2022-06-08 09:00:04.061210421 +0200
+@@ -43,7 +43,7 @@
+ #include "processor/disassembler_x86.h"
+ #include "processor/logging.h"
+
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+
+ namespace google_breakpad {
+
+--- a/src/processor/disassembler_x86_unittest.cc 2022-06-08 10:30:23.370615114 +0200
++++ b/src/processor/disassembler_x86_unittest.cc 2022-06-08 10:30:44.003341412 +0200
+@@ -30,7 +30,7 @@
+
+ #include "breakpad_googletest_includes.h"
+ #include "processor/disassembler_x86.h"
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+
+ namespace {
+