summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-27 01:47:11 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:36 +0200
commit33242f2b8381e6f9a0a5106aad95a9b7bee82671 (patch)
tree564c6130dc1bf0abdabb23f2ff9375547f02fb1d /dev-scheme
parentdev-scheme/guile-libyaml: switch to new guile mechanism (diff)
downloadgentoo-33242f2b8381e6f9a0a5106aad95a9b7bee82671.tar.gz
gentoo-33242f2b8381e6f9a0a5106aad95a9b7bee82671.tar.bz2
gentoo-33242f2b8381e6f9a0a5106aad95a9b7bee82671.zip
dev-scheme/guile-lzlib: switch to new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r100.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r100.ebuild b/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r100.ebuild
new file mode 100644
index 000000000000..8d4f27a9c2c6
--- /dev/null
+++ b/dev-scheme/guile-lzlib/guile-lzlib-0.0.2-r100.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile
+
+DESCRIPTION="GNU Guile library providing bindings to lzlib"
+HOMEPAGE="https://notabug.org/guile-lzlib/guile-lzlib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://notabug.org/${PN}/${PN}.git"
+else
+ SRC_URI="https://notabug.org/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+RDEPEND="
+ ${GUILE_DEPS}
+ app-arch/lzlib
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README.org )
+
+src_prepare() {
+ guile_src_prepare
+ eautoreconf
+}