summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/logging
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/logging')
-rw-r--r--dev-ruby/logging/Manifest2
-rw-r--r--dev-ruby/logging/logging-1.8.2.ebuild27
-rw-r--r--dev-ruby/logging/logging-2.0.0.ebuild25
-rw-r--r--dev-ruby/logging/metadata.xml5
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/logging/Manifest b/dev-ruby/logging/Manifest
new file mode 100644
index 000000000000..c5571d6fc1de
--- /dev/null
+++ b/dev-ruby/logging/Manifest
@@ -0,0 +1,2 @@
+DIST logging-1.8.2.gem 88064 SHA256 d7204b5ebacdf44756c1358b24ac78da39f63f5e6bfe0b6ffad0393de69d8c6d SHA512 3ecb691114994f91433250a4dbfb059ffd9d06420820b03619c1a9e7b79f22a217495cd27e28117f34f6aeb1517007d84d6340d6cfd1b9d62da3d4ba869b3641 WHIRLPOOL 4c4275e3c188a43ccec525297a55079bb06d26841394b4a449c3e8fea317e4ccbc428e2d444eea548ad9192076807cab983faa57295b127ea17b4174f49faabb
+DIST logging-2.0.0.gem 81408 SHA256 6be3aaa3566738a12f2c3aa6bcaa8b3348cf3a97688c9fb23f5cb08d11c2454d SHA512 cddd1a8fb083662c60ac06adfd3a1ddb3db19bd249ddddee7580a16c15f3c2886abb367113affd43c7dcb7fd9358fd334f812815a4fdf55b674ba086792d482e WHIRLPOOL 5f6c2586a2824a534d91d93103fed4487b447787c56f0d56ffe507d1bb199c84f1a75f18ed3bb828f2d022bf36997738a6cc219e3a1253f648dd7bf5f8b88020
diff --git a/dev-ruby/logging/logging-1.8.2.ebuild b/dev-ruby/logging/logging-1.8.2.ebuild
new file mode 100644
index 000000000000..6fdab1afa1dd
--- /dev/null
+++ b/dev-ruby/logging/logging-1.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="version.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flexible logging library for use in Ruby programs based on the design of Java's log4j library"
+HOMEPAGE="http://rubygems.org/gems/logging"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/little-plugger-1.1.3 >=dev-ruby/multi_json-1.3.6"
+
+ruby_add_bdepend "dev-ruby/bones test? ( dev-ruby/flexmock )"
diff --git a/dev-ruby/logging/logging-2.0.0.ebuild b/dev-ruby/logging/logging-2.0.0.ebuild
new file mode 100644
index 000000000000..ff6712f847d5
--- /dev/null
+++ b/dev-ruby/logging/logging-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flexible logging library for use in Ruby programs based on the design of Java's log4j library"
+HOMEPAGE="http://rubygems.org/gems/logging"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/little-plugger-1.1.3 >=dev-ruby/multi_json-1.10"
+
+ruby_add_bdepend "dev-ruby/bones test? ( dev-ruby/flexmock )"
diff --git a/dev-ruby/logging/metadata.xml b/dev-ruby/logging/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/logging/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>