summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-07 20:00:33 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-07 20:00:33 +0100
commit13403bcdc4e7549d2790b061ae4e9fc609801500 (patch)
tree614588c9cb98586667253bafaabf87f87da3332d /dev-ruby/facter
parentdev-ruby/facter: DEPEND on more recent dev-cpp/cpp-hocon (diff)
downloadgentoo-13403bcdc4e7549d2790b061ae4e9fc609801500.tar.gz
gentoo-13403bcdc4e7549d2790b061ae4e9fc609801500.tar.bz2
gentoo-13403bcdc4e7549d2790b061ae4e9fc609801500.zip
dev-ruby/facter: Remove old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/Manifest2
-rw-r--r--dev-ruby/facter/facter-3.14.3.ebuild114
-rw-r--r--dev-ruby/facter/facter-3.9.2-r1.ebuild91
3 files changed, 0 insertions, 207 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 620de77227b8..2a3332a287fd 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,4 +1,2 @@
-DIST facter-3.14.3.tar.gz 395278 BLAKE2B bda071fb92d337e2d6e58faaa33a6b135b6dfd3b6f4077af3b872bd44191629810fe99a7a1f8d9e3b16c4ff45ba587730bccb0652dcd85f4562120def42c7f38 SHA512 abd7cb3e102bff7635d6b2c17e5650e0a7b7be5ed6b81003df17053f0c9c4887f7db948714daaa313c7569bcc788ab18b0361a57395cd5118a6be38d571794df
DIST facter-3.14.5.tar.gz 395892 BLAKE2B c8f98716f4abca8d5f32c1cbfa79437b4021b1994476a31f7c00fc092f02aa08ed01eff4357368e140763bd3d39a38915c99606914e697ff8c769c9f0dd26638 SHA512 387f3d4c654ce3231129dbf6c22ccb04023d73006e4709b330b11ac01ef55831c618d80171ffb8de455be2a12e339a2b52ab782b0ed97e2dbfeaca2692ed951d
DIST facter-3.14.6.tar.gz 397339 BLAKE2B 74fae02a70194fd85789428c779f000e6b6750f52ecb0c713d6b772b3592a1974835367b148d046f849d61704adf82d93f519b86ecfe0007fb492f880a2aebca SHA512 6c17ba200fe82a2223b76505c29c6fb7bce2bff6e795316ea0b91d2fc8bc42bed9b930ba9c5d7b3851fd36fe93fb20e81a9cbc919589d4012e989234be1ba787
-DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.14.3.ebuild b/dev-ruby/facter/facter-3.14.3.ebuild
deleted file mode 100644
index 30611286b2d5..000000000000
--- a/dev-ruby/facter/facter-3.14.3.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=sys-devel/gcc-4.8:*
- dev-cpp/cpp-hocon"
-COMMON_DEPEND="
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- >=dev-libs/boost-1.54:=[nls]
- <dev-libs/boost-1.70.0
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
- ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- # be explicit about the version of rspec we test with
- sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
- CMakeLists.txt || die
- # be more lenient for software versions for tests
- sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
- -e '/rspec/ s/2.11.0/2.11/' \
- -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
- # patches
- default
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.9.2-r1.ebuild b/dev-ruby/facter/facter-3.9.2-r1.ebuild
deleted file mode 100644
index 8d687d2b690d..000000000000
--- a/dev-ruby/facter/facter-3.9.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${S}/all/${P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 sparc x86"
-
-BDEPEND="
- >=sys-devel/gcc-4.8:*
- >=dev-libs/leatherman-1.0.0
- dev-cpp/cpp-hocon"
-CDEPEND="
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- >=dev-libs/boost-1.54[nls]
- <dev-libs/boost-1.70.0
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-
-RDEPEND="${CDEPEND}"
-DEPEND="${BDEPEND}
- ${CDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- # Remove the code that installs facter.rb to the wrong directory.
- sed -i '/install(.*facter\.rb/d' lib/CMakeLists.txt || die
- sed -i '/install(.*facter\.jar/d' lib/CMakeLists.txt || die
- # make it support multilib
- sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
- sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
- # make the require work
- sed -i 's/\${LIBFACTER_INSTALL_DESTINATION}\///g' lib/facter.rb.in || die
- # patches
- default
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DUSE_JRUBY_SUPPORT=FALSE
- -DBLKID_LIBRARY=/$(get_libdir)/libblkid.so.1
- )
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-
- # need a variable file in env.d :(
- diropts -m0755
- dodir /etc/env.d
- echo -n "FACTERDIR=/usr/$(get_libdir)" > "${D}/etc/env.d/00facterdir"
- fperms 0644 /etc/env.d/00facterdir
-}