summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-10 10:54:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-10 11:34:51 +0100
commit8ad0cca6b5a7284c5e7ea531582c2c58420e814c (patch)
tree7a612a78931a748e4141515e8f3db9a3e2edc789 /dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild
parentdev-ros/rqt_py_common: Bump to 0.3.13. (diff)
downloadgentoo-8ad0cca6b5a7284c5e7ea531582c2c58420e814c.tar.gz
gentoo-8ad0cca6b5a7284c5e7ea531582c2c58420e814c.tar.bz2
gentoo-8ad0cca6b5a7284c5e7ea531582c2c58420e814c.zip
dev-ros/rqt_py_console: Bump to 0.3.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild')
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild
new file mode 100644
index 000000000000..6498ac8b31e5
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.3.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"