summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-20 04:25:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-20 04:50:15 +0200
commitf175ecd021c2dc464199025f6ac826da737d3472 (patch)
tree0ac642e486a05243c7bf5e9cfd44057f8de0ea00 /dev-python
parentdev-python/botocore: Bump to 1.19.0 (diff)
downloadgentoo-f175ecd021c2dc464199025f6ac826da737d3472.tar.gz
gentoo-f175ecd021c2dc464199025f6ac826da737d3472.tar.bz2
gentoo-f175ecd021c2dc464199025f6ac826da737d3472.zip
dev-python/boto3: Bump to 1.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0269df6771dd..b1ab3d250a60 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -20,3 +20,4 @@ DIST boto3-1.15.6.tar.gz 335618 BLAKE2B 6f3816b6363757ea1dbdef4bd710a68f07b513d2
DIST boto3-1.15.7.tar.gz 335640 BLAKE2B 01becc9a36fc03937153fc7d4a37b5630bb1c1d6f72ff9420de73a05f4ef7e5e39561e4175b6f652241d15efae708123b41673d9d69453b9b902c0f1568282b1 SHA512 4b612fc51e453af77e84ddbe5d3ee8e03e25be37a2b8fe65a960c22b8ee3423b1ddf0a482a189378e470500b3fe78af615571f15f9fb8fa86147a4334ef22ffa
DIST boto3-1.15.8.tar.gz 335724 BLAKE2B 4b034d21108bcf7fc100f71e534e348dfd72cf1ffea7e4ae53fa420e05c1e854216095e3179c4ce16c893a5bd32665830fc5ef3c3a4f0a011797b227ac53501d SHA512 dc6b9816fe58401a391aee2843698d8245141cb9735cc8b3c27181388ce8df070649e15d437ad96bbe3948061c97b0285e323c48e298c57271cd83d11180c768
DIST boto3-1.15.9.tar.gz 335977 BLAKE2B 9c0e1bfd11408085fe758552ace077dd2db01cb29f038d1f1559f41c6c0921a19457bfc818502d6a36ce9f7f931b75a20a0f0ba8d71bf93217c7b7f1be973c56 SHA512 0d0eb897dd526c5a19308150f28482c8f84ecab6f66d0cbf2c169da44bf55765cd8ee853360867788cb6a99784100e773104fb8c35511ad18d3a058843c50438
+DIST boto3-1.16.0.tar.gz 337077 BLAKE2B 512dffb58da14fda1d30e2359541c2e59ca1786bd83c5dc8cf9ddf7985555ff0dc53a16e2f41bb5be2a781ff114cd72aaa87ae84776f007776e5b3a0b0dba444 SHA512 8772dae3a531bfd6249e67d752e1737830ae39d28d151265b72c637f8090c6c2e76adbe4c8a83ec80dc888acef710211106b97fa90af41bb292b68c8d4b30393
diff --git a/dev-python/boto3/boto3-1.16.0.ebuild b/dev-python/boto3/boto3-1.16.0.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}