summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-07 15:28:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-07 16:10:30 +0200
commitc3aee9027cadbe0f4105d05bd3075ebbe534cb23 (patch)
tree18f328c798bb697040413fb7468a177158e9ee14 /dev-python
parentdev-python/astroid: Bump to 3.3.1 (diff)
downloadgentoo-c3aee9027cadbe0f4105d05bd3075ebbe534cb23.tar.gz
gentoo-c3aee9027cadbe0f4105d05bd3075ebbe534cb23.tar.bz2
gentoo-c3aee9027cadbe0f4105d05bd3075ebbe534cb23.zip
dev-python/hcloud: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hcloud/Manifest1
-rw-r--r--dev-python/hcloud/hcloud-2.2.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 806dec255b60..b9580b3fdaf0 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,3 +1,4 @@
DIST hcloud-python-2.0.1.gh.tar.gz 117015 BLAKE2B e795ea4a114c8e2c71554f84646b574e94030c6e724456786a437cc58d3dd96118c274111bc3787d8e7074b81f0c2493b3c6c5b824f6a8acb6d3a70b4dd75d29 SHA512 2507687324579240d2ff89287a6bd8e90dd33bb1290514c925e7e786330032187fdf133af196a6c0529ecb7018003356e299fc00cbf5bf2819d1f8e229702a04
DIST hcloud-python-2.1.0.gh.tar.gz 118173 BLAKE2B f350db9a552507e4770df180f7df82cbd3943aea64d827d7c9b05eae63dee5a92e410ad2d68766920f5b65b85788b4762313190b53ebbdba07bd64c7d62a8565 SHA512 80d2aec96c1b4303ba4827e938f33191fb3c150c15e7809e4f5b99b3c0b2af40ce04c1737207568acf9b20b38f0bd47dd223fe18eb093129ccdfe84992969caf
DIST hcloud-python-2.1.1.gh.tar.gz 118633 BLAKE2B 0072f8a6615ea917336429ef2b56840f1be8906bed9bd0793b47c4faa557e10bda368f8c3edcbc1b8ede6c39b384062038f665ae3e6beb589c747f1238a94572 SHA512 b98b62c99ffa31537baad35d0de0bee99a90dce95ecabfec8500e2172d520a3d819b870f001924cebeee7475905452ec2d5cc0bad15f763d16a423ddbe0171f8
+DIST hcloud-python-2.2.0.gh.tar.gz 119610 BLAKE2B 2b2bdc7416bc08464a7d6456cd935002f43b84d3728fb54ca3b132ac50959151a5c9c4ed75e256ca1dfa40a225cd8e4b0d54a4885497925e5222b00e5ccd5e1f SHA512 88b3ac155d7ee64ba41c1dced6546061287f2cd576c1f4bd95f46d1337c25efb4e25d0856a0c92cec1e97a133aafda8c024a79ef04df90bd29a1cd1318319166
diff --git a/dev-python/hcloud/hcloud-2.2.0.ebuild b/dev-python/hcloud/hcloud-2.2.0.ebuild
new file mode 100644
index 000000000000..64eceb0a363c
--- /dev/null
+++ b/dev-python/hcloud/hcloud-2.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}