summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-20 07:51:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-20 08:55:52 +0100
commitb9f490a5afa95236f5847c747d1e1c51194b4b0c (patch)
treebee20b27a29ff976d6d4498d7253d3f35f2dc222 /dev-python
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-b9f490a5afa95236f5847c747d1e1c51194b4b0c.tar.gz
gentoo-b9f490a5afa95236f5847c747d1e1c51194b4b0c.tar.bz2
gentoo-b9f490a5afa95236f5847c747d1e1c51194b4b0c.zip
dev-python/simsimd: Bump to 6.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-6.0.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 2050f98df455..70c41ace8411 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,2 +1,3 @@
DIST SimSIMD-5.9.11.gh.tar.gz 204255 BLAKE2B 6c67f47bf2beb41b8f6e091874c808a9be0da307d6bc7af5d6cca62435d1a4199cff7444b8b9f0ce04dbdd779641d635b8e7545512cfeb782ca81ef0f6e74e2e SHA512 eae6b0a509198de09a6d47c207554cc330ad1242b3a1d98d74d0fcb0c960052de1765e05d2bbe4bbb295224266dc393890a159b7fa933c6d7725685a5e50d1ec
DIST SimSIMD-6.0.6.gh.tar.gz 208136 BLAKE2B e9c3027d278a73ebc5b9f89454bf3ccad68b8ebe82ccda0da743769c5932e28f3bcb2e91e6a08badc03ac65c9e1949480b30f17f2a686972ffc22e2905952eb0 SHA512 8d8bc13e1342a42245827f36b1b544e4d8dc9e496b34b7443fdc98747880b477d4f2a6e4a425054717538057d7f4da75573b621c717b59f63f3a6459f90b1480
+DIST SimSIMD-6.0.7.gh.tar.gz 208361 BLAKE2B 682105bfc9dd4b730618ae18622666ac1cb8b1b542acaae78f0d3fac830a513ecb8491e7ba603e4a35a97608ee4b3d3a2f5e2eb4e5bd51f7a0625423641cbea2 SHA512 c65beb5df6db2f6b5fbbdd8fc5d043bafb29239a6ad459cc2a6a81314b88759dbb35ea848fb16c8c61f354f271dae08adb4c7fd92cd5b6817191897e96c476d9
diff --git a/dev-python/simsimd/simsimd-6.0.7.ebuild b/dev-python/simsimd/simsimd-6.0.7.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-6.0.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}