summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 15:34:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 15:37:34 +0200
commit6e0c8e02fc7083b8fcbb1b0d8b75af5dece8d961 (patch)
tree518b8974c90aea0d6de4700ae079c5992d58cec4 /dev-python
parentdev-python/trove-classifiers: Remove old (diff)
downloadgentoo-6e0c8e02fc7083b8fcbb1b0d8b75af5dece8d961.tar.gz
gentoo-6e0c8e02fc7083b8fcbb1b0d8b75af5dece8d961.tar.bz2
gentoo-6e0c8e02fc7083b8fcbb1b0d8b75af5dece8d961.zip
dev-python/pytest-httpbin: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-httpbin/Manifest1
-rw-r--r--dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch31
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild43
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index bf5af2cacf98..d7f45743003d 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1,2 +1 @@
-DIST pytest-httpbin-1.0.2.gh.tar.gz 18727 BLAKE2B 56a7fa1c1694cad98815fc6c6f676b509942fa1fca192ecb4cb5a0d9f325d7df6ddb3a3ac67d884c8f8caba807677351c42c28a3bcba80b9196e74d666951cc2 SHA512 b4adac1c37506391d83f7772814b4a9ce5134cc6834d8758e71d39610f8b29e57e72b11b2233be51e41b2c36bc305d40fc4b260a7f83d10390f4e940df8aa366
DIST pytest-httpbin-2.0.0.gh.tar.gz 19799 BLAKE2B 7725bc958417c076ee920abce83bdad8295bc4c9551500040867650d54c306e79a1ea92b013124b793058103fc9685dbb2202be5f1b2da935509f68457d63d68 SHA512 62876590bacae6601739f5cc2eccb087024e16731afc9613b5e6928c2a2f64b73418ddcb3c4f13a4bfe1f074510f922d85411d05ebf66f123a4a09d535771b64
diff --git a/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch b/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
deleted file mode 100644
index 02f63bffa72d..000000000000
--- a/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -dupr a/pytest_httpbin/serve.py b/pytest_httpbin/serve.py
---- a/pytest_httpbin/serve.py 2019-02-11 20:54:14.000000000 +0100
-+++ b/pytest_httpbin/serve.py 2019-11-22 15:50:17.407769297 +0100
-@@ -116,6 +116,7 @@ class Server(object):
-
- def stop(self):
- self._server.shutdown()
-+ self._server.socket.close()
-
- @property
- def url(self):
-Only in b: pytest_httpbin.egg-info
-Only in b/tests: __pycache__
-diff -dupr a/tests/test_httpbin.py b/tests/test_httpbin.py
---- a/tests/test_httpbin.py 2019-02-11 20:54:14.000000000 +0100
-+++ b/tests/test_httpbin.py 2019-11-22 15:59:53.955324547 +0100
-@@ -1,3 +1,4 @@
-+import sys
- import unittest
- import requests
- import pytest_httpbin
-@@ -40,6 +41,8 @@ def test_httpbin_join(httpbin):
- def test_httpbin_str(httpbin):
- assert httpbin + '/foo' == httpbin.url + '/foo'
-
-+@unittest.skipIf(hasattr(sys, 'pypy_version_info')
-+ and sys.hexversion >= 0x03000000, 'hangs on PyPy3')
- def test_chunked_encoding(httpbin_both):
- assert requests.get(httpbin_both.url + '/stream/20').status_code == 200
-
-Only in b: .tox
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild
deleted file mode 100644
index ef92b210fea8..000000000000
--- a/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
-HOMEPAGE="
- https://github.com/kevin1024/pytest-httpbin/
- https://pypi.org/project/pytest-httpbin/
-"
-SRC_URI="
- https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/httpbin[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
-)
-
-EPYTEST_DESELECT=(
- tests/test_server.py::test_redirect_location_is_https_for_secure_server
-)
-
-distutils_enable_tests pytest