summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-16 11:40:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-16 14:08:52 -0500
commit6c5170fe6c7767fc0722fec5cfc8a818fdaf40b0 (patch)
treeb0021b1dc04f3fda94e0b1fdb87058a29b67dd3c /dev-python
parentsys-kernel/gentoo-sources: Linux patch 5.4.166 (diff)
downloadgentoo-6c5170fe6c7767fc0722fec5cfc8a818fdaf40b0.tar.gz
gentoo-6c5170fe6c7767fc0722fec5cfc8a818fdaf40b0.tar.bz2
gentoo-6c5170fe6c7767fc0722fec5cfc8a818fdaf40b0.zip
dev-python/boltons: fix tests when pytest-qt is installed
This has no relation to QT, but being present breaks 1 test. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boltons/boltons-21.0.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/boltons/boltons-21.0.0.ebuild b/dev-python/boltons/boltons-21.0.0.ebuild
index ce1998c8a880..dbdaa4c469dd 100644
--- a/dev-python/boltons/boltons-21.0.0.ebuild
+++ b/dev-python/boltons/boltons-21.0.0.ebuild
@@ -23,3 +23,8 @@ DOCS=( CHANGELOG.md README.md TODO.rst )
PATCHES=(
"${FILESDIR}"/${P}-python3.10.patch
)
+
+python_test() {
+ # failure in test_exception_info with pytest-qt
+ epytest -p no:pytest-qt
+}