summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-31 07:40:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-31 07:46:40 +0100
commit67d1ce149b57321c9187f057e5a0ab1827e7f881 (patch)
treeba18ca470d53b558e67ef7a26fcd73c0d841fd2f /dev-python
parentxfce-base/thunar: Bump to 1.8.12 (diff)
downloadgentoo-67d1ce149b57321c9187f057e5a0ab1827e7f881.tar.gz
gentoo-67d1ce149b57321c9187f057e5a0ab1827e7f881.tar.bz2
gentoo-67d1ce149b57321c9187f057e5a0ab1827e7f881.zip
dev-python/pytest-xprocess: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.13.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index d41ea14f99c1..6958ed0da9ef 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.12.1.tar.gz 12078 BLAKE2B 30c3c2b41e79b79c5a18911c325ff273b80c45f29d269b96c4085c0c78a6897b2064eb1d2e83f9c061c4663d2f52d88230d9e87ea2ba4d114c6e04f42aa50a5e SHA512 fda868a12a056070afd5838c4bc466b4906a7138f685d4a0e6e0adbd975e5a1a2b9b37b8de36a45fb700e02ca14ae219cfe29c467f8d03e55d2a375a7efc9927
+DIST pytest-xprocess-0.13.1.tar.gz 10273 BLAKE2B 0c2a8bdf5e31543b32ada50f2bb5e1a09b45de820064807bf41321638d11d6b6fea28fd2a8c795e7bc6f7ac7370a3e78988e8aee318fad9df194fd3b06cce7cd SHA512 e0ab9e13d7f90ffca1bb3646e5789582806519ff5e665e13ed0db00896d799a7828b39e7657e947783d15ec1a961b33c1c981e39069dd298bf352826dbdc496f
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.13.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.13.1.ebuild
new file mode 100644
index 000000000000..5f63c2ba8f59
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest