summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-17 18:41:50 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-17 18:48:27 +0200
commit2a93ab9e76da596fd471c3b3fb333f4232348889 (patch)
treec0233df8d2b61522042abf41a9965e8187db5176 /dev-python
parentdev-python/bibtexparser: add 1.2.0 (diff)
downloadgentoo-2a93ab9e76da596fd471c3b3fb333f4232348889.tar.gz
gentoo-2a93ab9e76da596fd471c3b3fb333f4232348889.tar.bz2
gentoo-2a93ab9e76da596fd471c3b3fb333f4232348889.zip
dev-python/fritzconnection: add 1.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.9.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 9cde0957db70..4ec8e5cf332c 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -2,3 +2,4 @@ DIST fritzconnection-1.7.1.tar.gz 77805 BLAKE2B 4012975205320cc1c65ace64f515e1a9
DIST fritzconnection-1.7.2.tar.gz 77880 BLAKE2B bb27d1cc8ccdce17a73ddc6a1f3fcb1187976dcaca28f773a6aad9c07f3dfa80be686d065d060fbf174b60b31bc589f26e6f48ae655a69b4a7ad2864d434156b SHA512 2ab6b010750e7dc7dd010fc51c3fa41ab2eee58c5f310f187e998183950a2ed2668a13a4a4a39bdb27fb1b0a8f69cfff47256ebd3b543128710368689551dc87
DIST fritzconnection-1.8.0.tar.gz 77615 BLAKE2B aedcc3b116b6ce7ce14feb75714ee6e5a5ea667f7cb5e3124caa61e9b638e91e95a2520184869d088ceee7a6fd242c649660e7bb9ca81920f22954fc01ae3682 SHA512 4a65e715151fcd356ece60b9966560d80e4144d53f0684774af8f669fb83aa87124870ec1dfb29cbd381c73a711797f837b09abb620dfbb94722cba007fdf80c
DIST fritzconnection-1.9.0.tar.gz 79389 BLAKE2B 58ffebd4451dea16ec4739d77f02e3e67cda4e332df94688cf6b293f6cb6d15277f4d7231805425782d3214f926f74f51da4b988e60cbea5d336bec7436f664c SHA512 cf6710dffa8e76ecd5217d592824735e2bbcd8e2860a333a64e75530fd18da2cf6578181173614a2169d81c4db17f657708809db6d67e092f740558b8b8fd3fd
+DIST fritzconnection-1.9.1.gh.tar.gz 79580 BLAKE2B 6972c92aabb9c516e2b4d3d18bea2daf8002a12c9939a5badd1ceb8f7539a243f99778a3ded0cd057850b54e9cb2a0ca9d2c31be688eaf81f4b279b74d10fc55 SHA512 55642cf1db581c62091d63fdfa9bf4fe36c545df686eae7d0f886b4ef8c186668e6f8fb7bc7786e13936764ea771e0dba79e62b57f19348dd562bf23a27d6369
diff --git a/dev-python/fritzconnection/fritzconnection-1.9.1.ebuild b/dev-python/fritzconnection/fritzconnection-1.9.1.ebuild
new file mode 100644
index 000000000000..e17900fb1b18
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="https://github.com/kbr/fritzconnection"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=dev-python/requests-2.22[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest