summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-20 07:30:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-20 08:22:24 +0200
commit1745aed51d47f6f6f9cda2a28f774f9d0c0ee109 (patch)
treedd944f3562ea898144eb5d8163a9c6c92a3221a3 /dev-python
parentdev-python/pytools: Bump to 2022.1.10 (diff)
downloadgentoo-1745aed51d47f6f6f9cda2a28f774f9d0c0ee109.tar.gz
gentoo-1745aed51d47f6f6f9cda2a28f774f9d0c0ee109.tar.bz2
gentoo-1745aed51d47f6f6f9cda2a28f774f9d0c0ee109.zip
dev-python/pytest-testinfra: Bump to 6.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index f8b7e5eaca36..6ae69cbb4836 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-6.7.0.tar.gz 79187 BLAKE2B 08678f381392fe8a1fe335adc90ac6dc67c5bfa33c87f4e9d81b439eaabd29c393b8dc80cc79625784e76e5b0e264cdfc272cddb531acefbac9a8327be46f7be SHA512 d11f30da0eae9f215173d3f84e6ba7965d926b8ef6c49619c2ccae3d3ff215f351b950eea019e6516a56de0aa7bc533658af978d827a3ad3d1c50e37902b6f91
+DIST pytest-testinfra-6.8.0.tar.gz 78611 BLAKE2B ab1f9732db6a5d88730f4989cc47dc2086844f9809754d9f7811a8f0f092cf3d1e6f48fac2596200bf8e354cfd4aa3dc767bc21139267813141c9522d2116453 SHA512 e0c044430ffae1772b937b405572ef05b6177a645aff7b96e1f779d4f68449241757efae137a03ea8aec28db5f91c0e71574ab52aebef0052ca99ea0ca08db23
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.8.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.8.0.ebuild
new file mode 100644
index 000000000000..5ccf9168fa88
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}