summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 08:32:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 08:33:33 +0200
commit9ee8f71e6edeb04b8f6487319f173173d766d01c (patch)
tree9792c365bb57a8921e86c09ef86cb305fda8dc7b /dev-python/xmlschema
parentdev-python/fakeredis: Bump to 1.7.5 (diff)
downloadgentoo-9ee8f71e6edeb04b8f6487319f173173d766d01c.tar.gz
gentoo-9ee8f71e6edeb04b8f6487319f173173d766d01c.tar.bz2
gentoo-9ee8f71e6edeb04b8f6487319f173173d766d01c.zip
dev-python/xmlschema: Bump to 1.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.11.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 49f92e7d0f6d..095fa9767007 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.10.0.tar.gz 396057 BLAKE2B 44facdb16e79ddf16ca798b937c4cf35444f9d31278c26121f179e5055134b82d425cc5b69a8a2e4fdd44388cbd3e96534b55794a267a3b4c0b606752ede533e SHA512 c4358b210cc96e46617cc11b1b7e2a4d69c1bd6489cc73602552b184f209eb90b13eff353741aa7b1dbc3ff8514f90b7bb331ac18ffc466b3ce36f42f7497899
+DIST xmlschema-1.11.0.tar.gz 453958 BLAKE2B d6879e0f0445dad7e86d7b11e14d3f249b3cde5242c7cde7c327005fb4268ae9f20b4bf0bc3c140284e82842e09cbcdc2d12a7f8df0bede85ffc8db39989ed49 SHA512 507b57b8d4f48eb9f2463898ad0bd245791a8c8086a544d45da1fb2d4f6edafa5e555d44bdba50974408f14251cb8acae2dfc2c1b5c4544088f336fdfee0793a
diff --git a/dev-python/xmlschema/xmlschema-1.11.0.ebuild b/dev-python/xmlschema/xmlschema-1.11.0.ebuild
new file mode 100644
index 000000000000..02ebb8c6be86
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}