summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 20:24:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-24 20:35:14 +0200
commitdb5b72828bf65e44acd53887740ca229b285eb2d (patch)
tree563840f21e6a40d5c927aed9243050610a67eb5d /dev-python/watchfiles
parentdev-python/watchfiles: Remove old (diff)
downloadgentoo-db5b72828bf65e44acd53887740ca229b285eb2d.tar.gz
gentoo-db5b72828bf65e44acd53887740ca229b285eb2d.tar.bz2
gentoo-db5b72828bf65e44acd53887740ca229b285eb2d.zip
dev-python/watchfiles: Fix version number in metadata
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchfiles')
-rw-r--r--dev-python/watchfiles/watchfiles-0.15.0-r1.ebuild (renamed from dev-python/watchfiles/watchfiles-0.15.0.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/watchfiles/watchfiles-0.15.0.ebuild b/dev-python/watchfiles/watchfiles-0.15.0-r1.ebuild
index 016dfca13ef4..aeab77a1d524 100644
--- a/dev-python/watchfiles/watchfiles-0.15.0.ebuild
+++ b/dev-python/watchfiles/watchfiles-0.15.0-r1.ebuild
@@ -96,6 +96,13 @@ QA_FLAGS_IGNORED=".*/_rust_notify.*"
distutils_enable_tests pytest
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # fix version number
+ sed -i -e "/^version/s:0\.0\.0:${PV}:" Cargo.toml || die
+}
+
python_test() {
rm -rf watchfiles || die
epytest