summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 03:55:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 04:10:26 +0200
commit3452c47331f2fb8de76ccda2969c5af5e36227a8 (patch)
tree376be90a72ab3e1a7dac4ca4f718a949d42a3466 /dev-python/uv
parentapp-cdr/cdemu-daemon: Bump to 3.2.7 (diff)
downloadgentoo-3452c47331f2fb8de76ccda2969c5af5e36227a8.tar.gz
gentoo-3452c47331f2fb8de76ccda2969c5af5e36227a8.tar.bz2
gentoo-3452c47331f2fb8de76ccda2969c5af5e36227a8.zip
dev-python/uv: Bump to 0.2.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.2.23.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 2e9d4bb9f77d..120c27a21276 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -6,3 +6,5 @@ DIST uv-0.2.18.gh.tar.gz 1303313 BLAKE2B d14280eb1d92b2c3f43dc272da66d7e3b790f62
DIST uv-0.2.20-crates.tar.xz 48761312 BLAKE2B 888ee349ef5849c0333e67d2ab2a0c80bc5bd66fdf2de3e2b9f11d62f48aa075a5b66e234800c987cbda134cd5621dc0de0ab8e9a6ab63ad4e19e7eff33c7ca9 SHA512 5b7d0d48400e90cd6cfe4d615fa9672cca08e028d5b25dca97d360729a7eec6a39bf8613d076291097a11c39851a5348e045f5ee17b27053ebfc1469bf516512
DIST uv-0.2.21.gh.tar.gz 1318725 BLAKE2B dc1cbce639a05050f7a2ca97f9ee45fab8099045970e9543174fd963b12a9a355abd69aebc37f7bc91d9884c9a882ec6f43148bdc6b20e52728675f1f3f5f5d7 SHA512 7923781117117ad5645df7792396248f8064f9107719797e5efe118b70dfd51f6e53403fe7aa87ffb7e32c9327543ba9b001ffeb95b69028695d2e75fc53e2b7
DIST uv-0.2.22.gh.tar.gz 1311461 BLAKE2B 8fa2b9fa12220995f25426c7865dd897850617bc838beaa697764ee6566ee81e7e265d57f44f792a1a87a4fcc15d1f4de3de0dda94bb5e8a1c1c03c887b589b6 SHA512 95e67e4fcbbf5712fd25574459e4f707606cdbbd3d34735a2dcdc75fa533d2dc02177b7f3ad09139bb09d5c700352670508440d639eb191142b9372c7a5f2998
+DIST uv-0.2.23-crates.tar.xz 63724280 BLAKE2B 32f66ef8a6580d1dd0b7369656784c40da7f1f060c4543b359aa4f45ce33926f56d0d02222acf888a0923317d4cc02e96e1d27b3dab84038bf3714d316399f4b SHA512 04a31a451beb68f0d884cde3a35260a71020453217cfb616703b2ea8fd7af273b850239f66b8e77b1c73f241b2a8945ff9833fd0f445f2c6f3aa3412fee3e0e8
+DIST uv-0.2.23.gh.tar.gz 1314282 BLAKE2B 0d662a513b77a4da73945c3eedfa381cd65ad615975b22790ccde2eb467b356a70eacff20a15d37fff6f7b41b155824b0fda9f715d3a45f02c37c5f992f6fe0b SHA512 6b0c8f65e51dc8bf0654976b8866cb225784d91f44af935b243507a404ac4f297697ea22df29da43038eb335938be04e42fda39cbb292fe02715841c9f818380
diff --git a/dev-python/uv/uv-0.2.23.ebuild b/dev-python/uv/uv-0.2.23.ebuild
new file mode 100644
index 000000000000..02d0a4fb4a54
--- /dev/null
+++ b/dev-python/uv/uv-0.2.23.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;b4435e2f3af10dab2336a0345b35dcd622699d06;pubgrub-%commit%'
+ [reqwest-middleware]='https://github.com/astral-sh/reqwest-middleware;21ceec9a5fd2e8d6f71c3ea2999078fecbd13cbe;reqwest-middleware-%commit%/reqwest-middleware'
+ [reqwest-retry]='https://github.com/astral-sh/reqwest-middleware;21ceec9a5fd2e8d6f71c3ea2999078fecbd13cbe;reqwest-middleware-%commit%/reqwest-retry'
+)
+
+inherit cargo check-reqs
+
+CRATE_PV=0.2.23
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/uv-${CRATE_PV}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # remove patch.* that breaks GIT_CRATES
+ sed -i -e "/^\[patch/,\$s@^\(reqwest-middleware = \).*@\1 { path = \"${WORKDIR}/reqwest-middleware-21ceec9a5fd2e8d6f71c3ea2999078fecbd13cbe/reqwest-middleware\" }@" Cargo.toml || die
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${WORKDIR}/cargo_home/gentoo/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ # work around https://github.com/astral-sh/uv/issues/4376
+ local -x PATH=${BROOT}/usr/lib/python-exec/python3.12:${PATH}
+
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}