summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-15 08:16:09 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-15 08:16:09 +0100
commit26881ee0b3b5a0332c1a8eb6ce4752d69e34d725 (patch)
treee224ec515ac122685e13189abee08eaec8488e44 /dev-python/unearth
parentdev-python/types-setuptools: Bump to 69.0.0.20240115 (diff)
downloadgentoo-26881ee0b3b5a0332c1a8eb6ce4752d69e34d725.tar.gz
gentoo-26881ee0b3b5a0332c1a8eb6ce4752d69e34d725.tar.bz2
gentoo-26881ee0b3b5a0332c1a8eb6ce4752d69e34d725.zip
dev-python/unearth: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/unearth-0.13.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index ab589b0de01e..9b6582feb767 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1 +1,2 @@
DIST unearth-0.12.1.tar.gz 280628 BLAKE2B 2f96c818f5744b228d11d81fac8fb69da4df685b221f3a77424a1eb1d584e154798974ad4548c6f4264faa98f52cddeb94249e1c7e21136c50c08d97446149b6 SHA512 f726562191a3f2b9c189d16223b86307d79f0ca9e251c155e7acbc92160bed834c78064fbc5d745cd90b84ccd6eb2a24c737018fd670474921db0c7d15480576
+DIST unearth-0.13.0.tar.gz 280537 BLAKE2B 92e8cfd42c36d067eccba594ef6e510491156bb4e85d66ab0c1050029be3acf3308c21581d82a3ffd1982d1c8eb966d0be68d1fb8739621b52aa9e7073fd5963 SHA512 48bcdd2e61ffc6580ce19d0124e43aab0411efa913801cd74365ddefa3cec50eb0742997fd6359b6191a00314964b052ebf8d3ea5a173d37bc2cfedc1d030408
diff --git a/dev-python/unearth/unearth-0.13.0.ebuild b/dev-python/unearth/unearth-0.13.0.ebuild
new file mode 100644
index 000000000000..ddcdfe66abda
--- /dev/null
+++ b/dev-python/unearth/unearth-0.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}