summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:40:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:30 +0100
commit688dbc698be50316cc1119c35d55977dcb0ee424 (patch)
tree0b1597c1dbbf67e9ec92766bd013fba4fdf26a74 /dev-python/typeguard
parentdev-python/regex: Bump to 2023.3.22 (diff)
downloadgentoo-688dbc698be50316cc1119c35d55977dcb0ee424.tar.gz
gentoo-688dbc698be50316cc1119c35d55977dcb0ee424.tar.bz2
gentoo-688dbc698be50316cc1119c35d55977dcb0ee424.zip
dev-python/typeguard: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typeguard')
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-3.0.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 4c5fc9fdeec2..2b01cfd43441 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1,3 +1,4 @@
DIST typeguard-2.13.3.gh.tar.gz 37436 BLAKE2B a3cb616692119c64a9dc0d0bae25cc661b7974a0b6cf6632fa403f7c5430873570b1aaa310bc03843deee6f77a831c303ea9d9091db596eb565fce43980bbb13 SHA512 26c31ee9670650d1969320187a924d29d986894a38f1026af58f705b132b64be3b6e2ac34729f966f5d302d486334b5a5d9e65fb206245b82b0ff0852020b609
DIST typeguard-3.0.0.tar.gz 55330 BLAKE2B b0b764414c70e109e5bdddd1bfac06af5b0db8d8913e2777b4bec94598ae70f5ed323686f54d902c541c606e7ae32129b3a29099e59cfe5ff2ecad4e6991409e SHA512 367ffea6636817bf9ce492de575b38b1f15aec323d415476bdea271f01ee60073274fd955bdad0e554eb306fb4e516b80a29e5db10015cf47856279235e36c24
DIST typeguard-3.0.1.tar.gz 56196 BLAKE2B f53bfc7571063bc74588356cbff513311b0100079f42c3d8188ae430ffc1cf3ff2b7599a6ed0973ae02bb9d5d1818abc1c63a24d453592e630a4ac794ef4a5e4 SHA512 07d0276033730a6fc345aeabcbeb68f3b9740cb8336ed8ad731f75925d3bd9007ce050514bd98d39c1b85a4615ddf503420686ccd8ff6513c2610e40b8f89504
+DIST typeguard-3.0.2.tar.gz 58171 BLAKE2B d11b9592c191f131a48c8545a1ffbc4dcf4fc32f12dd0ba0bbab84c11ae1d6ba4cf6126fdc5d5b9b2ba81f07a3047f8328c7a8c29c1779238a04b12d4fe8b01c SHA512 a8f87494d4962cfa451ab266fb2958867acb677ec07acad0e8ccead16b9f3d59facffbe133de4e7808147caefb2b41c184b19bc82a812d041e90c3c1c1c0667a
diff --git a/dev-python/typeguard/typeguard-3.0.2.ebuild b/dev-python/typeguard/typeguard-3.0.2.ebuild
new file mode 100644
index 000000000000..45c5399f1af2
--- /dev/null
+++ b/dev-python/typeguard/typeguard-3.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.{8..9})
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False
+}