summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-01 09:17:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-01 09:21:22 +0200
commitf480f53915d83c36f7fdf3c64b59fa439904f3e6 (patch)
treecbb0157be17ae3461e05d5b421e4da0ffbcd6378 /dev-python/trio
parentdev-python/trove-classifiers: Stabilize 2024.5.22 ALLARCHES, #933315 (diff)
downloadgentoo-f480f53915d83c36f7fdf3c64b59fa439904f3e6.tar.gz
gentoo-f480f53915d83c36f7fdf3c64b59fa439904f3e6.tar.bz2
gentoo-f480f53915d83c36f7fdf3c64b59fa439904f3e6.zip
dev-python/trio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest1
-rw-r--r--dev-python/trio/trio-0.25.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 046872e4ce76..a93d70421ad8 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,2 +1 @@
-DIST trio-0.25.0.gh.tar.gz 599079 BLAKE2B d0615111fba3981c89d72a6eff93e9f500854e94f7227f3f235d4effa4ab53b9a280278b62db90c4a9612028edc5c9892b56464c9ee5b7e3c8120086dfc64e56 SHA512 0690193c501e054b5c2d96ea208d6a49b9ac860dd63a58c4b5cec5b5f6f197fc5eae0e2fae99ef498d5d1513b189a75504905bd5cc6dc34ae791e3451655933a
DIST trio-0.25.1.gh.tar.gz 600963 BLAKE2B f72df0069ff48f198f7c31221c721ffb127c4cac6c4e004547d62aa5f184673fde09e2baad5c383b206deffec4ef1b04dafad883dad0b2ced2625d72ac842887 SHA512 0a924a1c52ed5153e51cc3343c92b7f6218cf8c56ba2e66b6fe40d27d2acfa7475c3014b8fc5fd22e46df1782530a75f899dbb35d1c875331400957891bd70aa
diff --git a/dev-python/trio/trio-0.25.0.ebuild b/dev-python/trio/trio-0.25.0.ebuild
deleted file mode 100644
index 9a7f71be22f6..000000000000
--- a/dev-python/trio/trio-0.25.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio/
- https://pypi.org/project/trio/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- ' 3.10)
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# Bug https://bugs.gentoo.org/916756
-# distutils_enable_sphinx docs/source \
-# dev-python/immutables \
-# dev-python/sphinxcontrib-trio \
-# dev-python/sphinx-rtd-theme \
-# dev-python/towncrier
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
- # requires ruff
- _tests/tools/test_gen_exports.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- rm -rf trio || die
- epytest -p trio._tests.pytest_plugin \
- -m "not redistributors_should_skip" \
- --pyargs trio \
- --skip-optional-imports
-}