summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 11:42:16 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-05 11:42:16 +0200
commit66fe2b068779ea06a87b2c3a106fa1ba27c61974 (patch)
treed605dd6d13ee53fc21d97811d2b183c9d9e9f3bc /dev-python/trio
parentapp-text/zotero-bin: drop 6.0.27, 6.0.30 (diff)
downloadgentoo-66fe2b068779ea06a87b2c3a106fa1ba27c61974.tar.gz
gentoo-66fe2b068779ea06a87b2c3a106fa1ba27c61974.tar.bz2
gentoo-66fe2b068779ea06a87b2c3a106fa1ba27c61974.zip
dev-python/trio: add 0.26.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest1
-rw-r--r--dev-python/trio/trio-0.26.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index cea0b1c98fda..0353f5b475d8 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,2 +1,3 @@
DIST trio-0.25.1.gh.tar.gz 600963 BLAKE2B f72df0069ff48f198f7c31221c721ffb127c4cac6c4e004547d62aa5f184673fde09e2baad5c383b206deffec4ef1b04dafad883dad0b2ced2625d72ac842887 SHA512 0a924a1c52ed5153e51cc3343c92b7f6218cf8c56ba2e66b6fe40d27d2acfa7475c3014b8fc5fd22e46df1782530a75f899dbb35d1c875331400957891bd70aa
+DIST trio-0.26.0.gh.tar.gz 609710 BLAKE2B ec263e5db731760472111b8eb6a7d6ebdc476f8dc0976787692289caa5d5361a1a3db03d4713f14ee3198ad45dcec19c6c672af4af3860c3cd7ad5ff3e13bc8a SHA512 9a51f4e71795083ffd4a606e989583b1a93e45dc32f93d2d03bccaf32ca62a82daaf964676636363711b7ea1675dddd3eac1acae1be73b0fc570baef3c37c748
DIST trio-0f5fc6cbafa3e7c84f258d1865996d97ae67a318.gh.tar.gz 609698 BLAKE2B db34b8a3157b78340f75fc07d8c2dc333610d962c3849fce3906e643159904ef28cb94fed062c4607a114f9de3bfa822706c2ea6a5eef5833d17e25690c83603 SHA512 692092451376be2424faf395bbdc4f61bec91f6807a0f04d1c701fc2767a4c844830f93b01cf5a813febf9d267a52d968f4f5f8b983eb7cc5ffcb91cc716739a
diff --git a/dev-python/trio/trio-0.26.0.ebuild b/dev-python/trio/trio-0.26.0.ebuild
new file mode 100644
index 000000000000..01b349cf4ec8
--- /dev/null
+++ b/dev-python/trio/trio-0.26.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Bug https://bugs.gentoo.org/916756
+# distutils_enable_sphinx docs/source \
+# dev-python/immutables \
+# dev-python/sphinxcontrib-trio \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+ # requires ruff
+ _tests/tools/test_gen_exports.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf trio || die
+ epytest -p trio._tests.pytest_plugin \
+ -m "not redistributors_should_skip" \
+ --pyargs trio \
+ --skip-optional-imports
+}