summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-24 22:40:29 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-25 00:32:47 +0200
commit1fbb7d8512c50094071547f0c324541ab33d5073 (patch)
tree0a27e52cc66c5f3a9b74692e1a563c6cc7620c1f /dev-python/transitions
parentdev-python/transitions: add python3.9 support (diff)
downloadgentoo-1fbb7d8512c50094071547f0c324541ab33d5073.tar.gz
gentoo-1fbb7d8512c50094071547f0c324541ab33d5073.tar.bz2
gentoo-1fbb7d8512c50094071547f0c324541ab33d5073.zip
dev-python/transitions: drop old version
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/transitions-0.8.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/transitions/transitions-0.8.2.ebuild b/dev-python/transitions/transitions-0.8.2.ebuild
deleted file mode 100644
index 23b568a3c791..000000000000
--- a/dev-python/transitions/transitions-0.8.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
-HOMEPAGE="https://github.com/pytransitions/transitions"
-SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/graphviz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
-
- use examples && dodoc examples/*.ipynb
-}