summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-21 20:20:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-21 21:54:10 +0100
commitc1f7a41ccdf7f50cebeb9b5a30981dfeb301e800 (patch)
tree7c78fc7f3ca00db4911e4df53c01442e9ad4eba1 /dev-python/tqdm
parentdev-python/virtualenv: Bump to 20.2.0 (diff)
downloadgentoo-c1f7a41ccdf7f50cebeb9b5a30981dfeb301e800.tar.gz
gentoo-c1f7a41ccdf7f50cebeb9b5a30981dfeb301e800.tar.bz2
gentoo-c1f7a41ccdf7f50cebeb9b5a30981dfeb301e800.zip
dev-python/tqdm: Bump to 4.53.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.53.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index bc2eddeb5c1a..4dd885242533 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,4 @@
DIST tqdm-4.49.0.tar.gz 151935 BLAKE2B 790e2912a402795af9aba2e4db80cf41a7cb08267dad5946d89b4d9fb8b8c7a1dd65f33dcaf315bbe82862c0c2934b2dd2b8cee894c592d5a61ac61dd8c5126f SHA512 44197eb09b90551eb66c8b2e0dc97f6864fc91654465e7d478ece6ecd610242d8e378c6814f9d3e1cf05b2db1aa533743535051ad456ec5ef6d477be906ee217
DIST tqdm-4.51.0.tar.gz 152976 BLAKE2B f9cef9de6a77c21e40394edd006fbd8fa913af4d3a9a8ac68bd9fde81b1eebc404f6fab90d9aadc57ce2ccfbc3a2f8d8879b151f6283dc34edc25d70f69ae6e1 SHA512 04bb2a173b9b79b76844fedbc14572fa955232d1dcb6ac55b7265c4cc7a4f712f2c2965ac3bcb9e10ea1bd041593230b047365816bf508d457d873a2d4830d3f
DIST tqdm-4.52.0.tar.gz 180391 BLAKE2B f0dc1e991088deeb0160f227263c105dc0b2dd90be9be74eb0eecfc1195a6b831150d195ca6cfddeaef6deeef1b8c82df3240158792dfe9a238eb0c52730b570 SHA512 fe2161ac61528a4d3bf697dc6369fb06e2c0defb2275165a701a28b80bba98380ea156458b87a5c9c49d3fc6da56f05a54fbae935cf2a17d82eb5adaf79902f0
+DIST tqdm-4.53.0.tar.gz 179940 BLAKE2B 022fd8eae70a38306d201981bd6c2e469791abc86e3e10bf2bcbe4936e4e6791dc24b3e064c6adb830fd908a1544389fdba8f7017bee17632925c1bcc3d42349 SHA512 ffb06058a71e31497ced0b6b5ce8671a7e958968e0a08e1b68dc9f3a9acac415c1708f6669d369ab484bbc07a8fc06716ed32fde70f22c0dbd8242417f95a713
diff --git a/dev-python/tqdm/tqdm-4.53.0.ebuild b/dev-python/tqdm/tqdm-4.53.0.ebuild
new file mode 100644
index 000000000000..86b23f03a50c
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.53.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}