summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-28 04:45:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-28 04:45:28 +0200
commit04dd284b4b3cb92aebbddb7292942b9d2fab1ba1 (patch)
treede696d5da6e3a6e69bcc4165e4993fb147b8d2b0 /dev-python/tifffile
parentapp-admin/awscli: Bump to 1.34.7 (diff)
downloadgentoo-04dd284b4b3cb92aebbddb7292942b9d2fab1ba1.tar.gz
gentoo-04dd284b4b3cb92aebbddb7292942b9d2fab1ba1.tar.bz2
gentoo-04dd284b4b3cb92aebbddb7292942b9d2fab1ba1.zip
dev-python/tifffile: Bump to 2024.8.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2024.8.28.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index af18b90076ab..3535d05d410a 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,2 +1,3 @@
DIST tifffile-2024.8.10.gh.tar.gz 350933 BLAKE2B 72cbb36f9ee169e337235b9f9790c11ac92fcff0c46dd791c551bc91d080d05b237ab5d2f4d7cf55744af3a7b04e22cc952d643898527157fa16880272256118 SHA512 59edbecf3ab762d24f1f560dcd471036989003f9385b8d6e0480882df2cfbf81ef5ecc6c41d098e832227717d866e31d158129e17cb1f68bc3d8cf02e1944f90
DIST tifffile-2024.8.24.gh.tar.gz 351308 BLAKE2B daffd7179f1450c60acc63b78ee2870e29e1baa50eb1daf0540020a3e47048ba3622f7ed1512f17802a6c89d4d68975ced8ebe4c2779cb71a13893104c1233be SHA512 658b9e3f64e73c6e08627aaf5f8d15a55cf04c2002afa8694b8596dafdc8f84517a62e7b8369285edc43d0fb4990c54727fa33e591015093bbbbc066b8341a4a
+DIST tifffile-2024.8.28.gh.tar.gz 351568 BLAKE2B 4ee3c41f5ebb31b35e230c9784c89a43735d27b67e16d48a58ff2ee5ff0a28f3f84c2e02fd25ea1879b4adda0d70aae723a6ec93cb8f8b54e47680fb773c4d11 SHA512 5710de50e303f4012cd6bfdbbc4f6d4045b2917236dd268124df7326f36ef43b004bb4bed1b2d3b9444b55b2947b48a3882b6db2cb75582a990100e58c7d1105
diff --git a/dev-python/tifffile/tifffile-2024.8.28.ebuild b/dev-python/tifffile/tifffile-2024.8.28.ebuild
new file mode 100644
index 000000000000..a9bd677f4e53
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.8.28.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}