summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-07-06 11:28:09 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-07-06 11:28:53 +0200
commit1360918a6e371223a097eedddd082367dddcc430 (patch)
tree51b16d8bca26cbfe8ecaeccb1d77a1a5d71dab0d /dev-python/thrift
parentapp-accessibility/freetts: build without BSFIX, drop java-ant-2 (diff)
downloadgentoo-1360918a6e371223a097eedddd082367dddcc430.tar.gz
gentoo-1360918a6e371223a097eedddd082367dddcc430.tar.bz2
gentoo-1360918a6e371223a097eedddd082367dddcc430.zip
dev-python/thrift: Avoid file collision with dev-libs/thrift
Closes: https://bugs.gentoo.org/933272 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/thrift-0.20.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/thrift/thrift-0.20.0.ebuild b/dev-python/thrift/thrift-0.20.0.ebuild
index 7922b42cbef0..261fd69010bc 100644
--- a/dev-python/thrift/thrift-0.20.0.ebuild
+++ b/dev-python/thrift/thrift-0.20.0.ebuild
@@ -26,3 +26,10 @@ distutils_enable_tests unittest
python_test() {
eunittest test
}
+
+src_install() {
+ distutils-r1_src_install
+ # avoid file collision with dev-libs/thrift (bug #933272)
+ mv "${D}"/usr/share/doc/${P}/README.md \
+ "${D}"/usr/share/doc/${P}/ReadMe.md || die
+}