summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 12:14:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 12:56:18 +0200
commit5228aaa4b73c861d15c4cd0fb64502e447e27b46 (patch)
tree5bbbf380a0deabdc558c23376c9df43247c52d89 /dev-python/testresources/testresources-2.0.1.ebuild
parentdev-python/pbr: Port to py3.10 (diff)
downloadgentoo-5228aaa4b73c861d15c4cd0fb64502e447e27b46.tar.gz
gentoo-5228aaa4b73c861d15c4cd0fb64502e447e27b46.tar.bz2
gentoo-5228aaa4b73c861d15c4cd0fb64502e447e27b46.zip
dev-python/testresources: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testresources/testresources-2.0.1.ebuild')
-rw-r--r--dev-python/testresources/testresources-2.0.1.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/testresources/testresources-2.0.1.ebuild b/dev-python/testresources/testresources-2.0.1.ebuild
index 20aab49f4082..fac3d7bddf58 100644
--- a/dev-python/testresources/testresources-2.0.1.ebuild
+++ b/dev-python/testresources/testresources-2.0.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A pyunit extension for managing expensive test resources"
@@ -14,24 +13,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
test? (
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
)"
+distutils_enable_tests nose
+
python_prepare_all() {
sed \
-e 's:testBasicSortTests:_&:g' \
-i testresources/tests/test_optimising_test_suite.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- nosetests --verbose || die "Tests failed under ${EPYTHON}"
-}