summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-04-03 13:50:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-09 15:21:01 +0300
commit21cf6b428794cbe9168af003e55748cafcc1e46c (patch)
tree1f8722fbdd45b491aa3ae5f013bff068ca69873e /dev-python/spyder/files
parentdev-python/spyder-notebook: restrict spyder version to <5 (diff)
downloadgentoo-21cf6b428794cbe9168af003e55748cafcc1e46c.tar.gz
gentoo-21cf6b428794cbe9168af003e55748cafcc1e46c.tar.bz2
gentoo-21cf6b428794cbe9168af003e55748cafcc1e46c.zip
dev-python/spyder: add 5.0.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder/files')
-rw-r--r--dev-python/spyder/files/spyder-5.0.0-build.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/spyder/files/spyder-5.0.0-build.patch b/dev-python/spyder/files/spyder-5.0.0-build.patch
new file mode 100644
index 000000000000..be849e78e49f
--- /dev/null
+++ b/dev-python/spyder/files/spyder-5.0.0-build.patch
@@ -0,0 +1,37 @@
+diff --git a/setup.py b/setup.py
+index ff4f8ec..08a4f2d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -111,24 +111,6 @@ def get_packages():
+ return packages
+
+
+-# =============================================================================
+-# Make Linux detect Spyder desktop file (will not work with wheels)
+-# =============================================================================
+-class CustomInstallData(install_data):
+-
+- def run(self):
+- install_data.run(self)
+- if sys.platform.startswith('linux'):
+- try:
+- subprocess.call(['update-desktop-database'])
+- except:
+- print("ERROR: unable to update desktop database",
+- file=sys.stderr)
+-
+-
+-CMDCLASS = {'install_data': CustomInstallData}
+-
+-
+ # =============================================================================
+ # Main scripts
+ # =============================================================================
+@@ -196,7 +178,6 @@ def run(self):
+ 'Topic :: Scientific/Engineering',
+ 'Topic :: Software Development :: Widget Sets',
+ ],
+- cmdclass=CMDCLASS,
+ )
+
+