summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-16 14:54:28 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-17 09:48:08 +0200
commitdb423c41092fd9b0995ea6357b7ea5a120b29bad (patch)
tree49a81db821d0d361be21404b320c3f0433afa941 /dev-python/sphinxcontrib-programoutput
parentdev-python/exam: new package (diff)
downloadgentoo-db423c41092fd9b0995ea6357b7ea5a120b29bad.tar.gz
gentoo-db423c41092fd9b0995ea6357b7ea5a120b29bad.tar.bz2
gentoo-db423c41092fd9b0995ea6357b7ea5a120b29bad.zip
dev-python/sphinxcontrib-programoutput: bump to 0.15, add py3.7
Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14965 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-programoutput')
-rw-r--r--dev-python/sphinxcontrib-programoutput/Manifest1
-rw-r--r--dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.15.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-programoutput/Manifest b/dev-python/sphinxcontrib-programoutput/Manifest
index 36058ac820ef..3d63a0389b75 100644
--- a/dev-python/sphinxcontrib-programoutput/Manifest
+++ b/dev-python/sphinxcontrib-programoutput/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-programoutput-0.11.tar.gz 18267 BLAKE2B 790483b09a00199e4f6a4bb723827001e3dc252b294244ddb5ed3edc78cd8dde41fd0c5cab6d4fb715c85f8c447bf25d690b4f921341769de6d7d1c9dc7f4a71 SHA512 4aa655f8632093035de986fa31291f95e95c4c0f4d1458bb8c8cc077cca73d579b16a8bf103d7b34faafb2171c617c40200008d89186f8ed37a812459f0376cf
+DIST sphinxcontrib-programoutput-0.15.tar.gz 21772 BLAKE2B e3bf609315e0298e73bf37db0d7e4d5175121fd0b0c612083427d60ab10cbfc1bf65c572b9ce561b05c9adffe288df7f0b28d6f2daa44af197d22b99ec8d00f4 SHA512 08444118daf09e05c1318ee87a22fcccb7822b99d58d18cf46748aa32338f35519017839c233cd5176a5426cb5f55047039ee28a26f6f4ebd99a35b199c0ff19
diff --git a/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.15.ebuild b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.15.ebuild
new file mode 100644
index 000000000000..e52eb9c01f42
--- /dev/null
+++ b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to sphinx to include program output"
+HOMEPAGE="
+ https://sphinxcontrib-programoutput.readthedocs.io/en/latest/
+ https://pypi.org/project/sphinxcontrib-programoutput/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}