summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 07:42:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 08:08:35 +0100
commitde5816453cf331c6afb1df4f810f8c1a4c249146 (patch)
treecbda15ef08960d5a6ba5f15e317f5e72a7134c38 /dev-python/sphinx-autodoc-typehints
parentdev-python/tox: Bump to 4.4.3 (diff)
downloadgentoo-de5816453cf331c6afb1df4f810f8c1a4c249146.tar.gz
gentoo-de5816453cf331c6afb1df4f810f8c1a4c249146.tar.bz2
gentoo-de5816453cf331c6afb1df4f810f8c1a4c249146.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.22.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 21cec9a9a3e6..f6b28649404b 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -3,3 +3,4 @@ DIST sphinx-autodoc-typehints-1.20.1.gh.tar.gz 28374 BLAKE2B 87891c5ee6b1fa76b12
DIST sphinx-autodoc-typehints-1.21.5.gh.tar.gz 33282 BLAKE2B 9bed01a1de3f82f5f7f2809901c51dcacc7543920950dabf3a1d7ce87e0298337b0d9779d79cbfa58b2b0bfb2ab195f9957c83fc78ffc4837023733b9cef1f46 SHA512 b111832cb266bc2d48b3c60a3725b8f625581ce30e7f0c020cab83316f6f109db60031f214b6eeef02c181da63fec4bea4cf03cadda0a2c13e44c722f174be3e
DIST sphinx-autodoc-typehints-1.21.7.gh.tar.gz 34523 BLAKE2B e5ad3c02e9717d0cf19d54ce90f3b1f75537b224b16cd3fe2ed52ac471e5bea435455c611bbdb284d2ed0c1be13e7cc300b1af6957c6fdd6725b17f044d62be9 SHA512 7c0f3dd94a6f41df8630ff21303f3085efa7ad6c1b3a9137bf43bc8f748944f715984c5d55041fa30ea16cb15ab25cf612dc231c4426cf25dba6f68a85493890
DIST sphinx-autodoc-typehints-1.21.8.gh.tar.gz 35224 BLAKE2B b370690b6bb2ff6e7eaea668b73ac96af30c7d5c4e6352af76b522487f670524db754d5fd22c969f320f267dc75f13a01a0f5683cfc55a8d136bdfc651446d88 SHA512 c87bd9aec4afe6cd0341ca795f26cc1b808226a9d97f13f283e42aa64ac87814bd27fab44bc278b3affbe3e71508fe27a0a6ddcd4f48aef40d08096c379c1883
+DIST sphinx-autodoc-typehints-1.22.gh.tar.gz 35429 BLAKE2B d871de3d3a37b2632e6b43dcb4ce58fbf61bdfdb225650486fdffbbfff4148770f40096815d3e6807f4d3f789c0f7f7fdfef841a3d087f0b12e65671597207e3 SHA512 9fed312b5b63dcbf0b39e226486abd687e68c26eeb7303ee3049251c7007d7c364ceb196672ac16101b1a76493e0a0a4e1d9532e54eec250720a37f0c8f77fda
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.22.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.22.ebuild
new file mode 100644
index 000000000000..395c86133d9e
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}