summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 11:59:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:22:20 +0100
commit07c6f487a5824bfe13737299965a80bcc9d4dc73 (patch)
tree61745d882842188fdd0127f64b586ef9dde26453 /dev-python/shapely
parentdev-python/traitlets: Bump to 5.9.0 (diff)
downloadgentoo-07c6f487a5824bfe13737299965a80bcc9d4dc73.tar.gz
gentoo-07c6f487a5824bfe13737299965a80bcc9d4dc73.tar.bz2
gentoo-07c6f487a5824bfe13737299965a80bcc9d4dc73.zip
dev-python/shapely: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-2.0.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 4010cd22815c..a59a9303a3e5 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-2.0.0.gh.tar.gz 324420 BLAKE2B efe8aea8d9507bf2d2c31ca7dfaa6a531f71530243dd8c23046f4803d36e36b1636a07255c634fc5d6e30391aac260dcdaeb1f4c2aa73297a90f71134c1bbc15 SHA512 15e261901ada47ef2a9d2f213a2634152bc43799fd27421726b5e6525f91aef60c0bbc5f38e5185bf89ec795b5fa703688d2b08d4d3d14c9274515c5935157cb
+DIST shapely-2.0.1.gh.tar.gz 325843 BLAKE2B f6ae72c8544c236f6761be5bbc358161232319377a76d297eda317e61b97185ae62126b27963cb83798593ec2ce3f29d99bd74113e356b69b54da7586927d43b SHA512 878a4857f5408e2f779566f4885b3336eecd2ecfd685e9be3e306af2720ca4da3f7a1159ae65ad1eba441e0f9b347176d6c144563a9562ed8213e6f964d183c7
diff --git a/dev-python/shapely/shapely-2.0.1.ebuild b/dev-python/shapely/shapely-2.0.1.ebuild
new file mode 100644
index 000000000000..6c31a645aa99
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ rm -r shapely || die
+}