summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-22 06:55:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-22 07:08:09 +0200
commita5c1aedaaf4cc6c4532959a1876c8d7b108a0567 (patch)
tree8d7929d13615920f35f1f87294ebf81875171396 /dev-python/rq
parentsys-kernel/gentoo-kernel-bin: Bump to 5.15.118 (diff)
downloadgentoo-a5c1aedaaf4cc6c4532959a1876c8d7b108a0567.tar.gz
gentoo-a5c1aedaaf4cc6c4532959a1876c8d7b108a0567.tar.bz2
gentoo-a5c1aedaaf4cc6c4532959a1876c8d7b108a0567.zip
dev-python/rq: Bump to 1.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.15.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 4151e815827c..23b91a29ba7a 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1 +1,2 @@
+DIST rq-1.15.1.gh.tar.gz 633531 BLAKE2B e1cf463e54533a1a56fab98a66f4cfe2ef73da48ab965a10066b84050aa1ac72373328246236fbd45bdf3d026ffc355aa117a21047dce1cef16b18c6e96a0f3f SHA512 75228f037c5c731f7788bb18654f2e07a9af39f8980900166e07145887f7cbed06fbd7fb5513a770cee791d07a49d85a544b83f347cce6726d7745f8396e3aac
DIST rq-1.15.gh.tar.gz 633276 BLAKE2B 885b4ef343924b8f4a88c6c3e93bbed1b62022e72217922e874b8f6be36c3656110037f862bfe27f134d57c41d1b741e5fa23e6ab48fbd787ff08bf628a5e207 SHA512 b1c9614b376b74795436333cff6a5bb62795e73d95376e8e18b2472fda3eb720608d495c57e3c2c1b2c237b7fc409602828bea631c1b8905d7df71c74e6c705c
diff --git a/dev-python/rq/rq-1.15.1.ebuild b/dev-python/rq/rq-1.15.1.ebuild
new file mode 100644
index 000000000000..8c0bd028f82f
--- /dev/null
+++ b/dev-python/rq/rq-1.15.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+# Tests missing from sdist, as of 1.14.1
+SRC_URI="
+ https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}