summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 09:48:36 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-17 09:57:11 +0100
commit92dbfa55746fc69b6b1be2c990a1ec316027996e (patch)
treef81aeb5fa803977453d07d4dcba58103cf43b07f /dev-python/requests-mock/requests-mock-0.7.0.ebuild
parentdev-python/docker-py: Version Bump (diff)
downloadgentoo-92dbfa55746fc69b6b1be2c990a1ec316027996e.tar.gz
gentoo-92dbfa55746fc69b6b1be2c990a1ec316027996e.tar.bz2
gentoo-92dbfa55746fc69b6b1be2c990a1ec316027996e.zip
dev-python/requests-mock: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/requests-mock/requests-mock-0.7.0.ebuild')
-rw-r--r--dev-python/requests-mock/requests-mock-0.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/requests-mock/requests-mock-0.7.0.ebuild b/dev-python/requests-mock/requests-mock-0.7.0.ebuild
new file mode 100644
index 000000000000..7c3512b4736b
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}