summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2020-11-30 22:47:14 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-07 18:41:35 +0200
commit271cb56e621f9ce5fca615df93612fa85e72a0f2 (patch)
treedecd8d35c08123a2e02f23ee58d39189be82b2f8 /dev-python/reedsolomon
parentapp-portage/metagen: Address PythonCompatUpdate + fix 9999 (diff)
downloadgentoo-271cb56e621f9ce5fca615df93612fa85e72a0f2.tar.gz
gentoo-271cb56e621f9ce5fca615df93612fa85e72a0f2.tar.bz2
gentoo-271cb56e621f9ce5fca615df93612fa85e72a0f2.zip
dev-python/reedsolomon: fix ebuild, add necessary dependency
Unfortunately the buildtime dependency dev-python/cython is missing. This ebuild fixes this. Closes: https://bugs.gentoo.org/757486 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/18465 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/reedsolomon')
-rw-r--r--dev-python/reedsolomon/reedsolomon-1.5.4.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/reedsolomon/reedsolomon-1.5.4.ebuild b/dev-python/reedsolomon/reedsolomon-1.5.4.ebuild
index e3c9f2928bd9..70f3dc5d7f7a 100644
--- a/dev-python/reedsolomon/reedsolomon-1.5.4.ebuild
+++ b/dev-python/reedsolomon/reedsolomon-1.5.4.ebuild
@@ -16,6 +16,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
python_test() {
${EPYTHON} tests/test_creedsolo.py || die "creedsolo test failed with ${EPYTHON}"
${EPYTHON} tests/test_reedsolo.py || die "reedsolo test failed with ${EPYTHON}"