summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-26 05:37:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-26 05:37:47 +0200
commitfe050cca62367d14dee339f0195eec9b8d86d454 (patch)
tree2780ba3d5d29cc5c6a45e6876f0043e694c3f9e4 /dev-python/readthedocs-sphinx-ext
parentdev-python/virtualenv: Bump to 20.16.6 (diff)
downloadgentoo-fe050cca62367d14dee339f0195eec9b8d86d454.tar.gz
gentoo-fe050cca62367d14dee339f0195eec9b8d86d454.tar.bz2
gentoo-fe050cca62367d14dee339f0195eec9b8d86d454.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index 291394de79bf..e3db4345aea2 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1 +1,2 @@
DIST readthedocs-sphinx-ext-2.1.9.tar.gz 12465 BLAKE2B 2ee1e0a5e7202dbe57c0dcfc796f8019d057178b59cf832e77b742d5e1b039804aca830109ba10b393577549b5c55ab5707b8071b230f998ea2b91653be2176e SHA512 dc99335ce01a882d9e5509216d5830ef1b943b41f92836433c3a06592edc127a9ed2de39091d6a4fcad941f90be135293592394f4b2c4d8f13955cdbb92f3887
+DIST readthedocs-sphinx-ext-2.2.0.tar.gz 12721 BLAKE2B 3ac02a96a059e6d6b94af4318a5e816f8664e1164edb315d7540d1bfcce3b0edbbe9d567b0dc2931179cb309714175c64a3684b9d568551cc240ccbefc77a10a SHA512 8f7009a0716751de2fe2fed726aa08bb382d15ef6c4fb66e6c29537f985a92ab7cc137f81a4f6200e794cb7f495ebf561356194f57c694509b67e7686bef52c5
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.0.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.0.ebuild
new file mode 100644
index 000000000000..5daa4f214a46
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest