summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 09:01:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:49 +0200
commite82f7f754720a0ed41ceb6122e786fc79c6149b0 (patch)
treef3c26c4710b7231b511f4a82aa39a75395fee1a9 /dev-python/rdflib
parentdev-python/uritemplate: Bump to 4.0.0 (diff)
downloadgentoo-e82f7f754720a0ed41ceb6122e786fc79c6149b0.tar.gz
gentoo-e82f7f754720a0ed41ceb6122e786fc79c6149b0.tar.bz2
gentoo-e82f7f754720a0ed41ceb6122e786fc79c6149b0.zip
dev-python/rdflib: Bump to 6.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-6.0.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index edf5a67e38bc..4ad1ee175750 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1,2 +1,3 @@
DIST rdflib-5.0.0.tar.gz 818586 BLAKE2B d0046590b00211ccb4f0f586dc829c061a5f426b1cefed44a63d21d46396354b9012dbe0a63c8f9de138b25ca7d73ba624c49da6fb305ececd983c62c917fd8a SHA512 ba98ab6a7bb9d993d11c559a739761f297282eb9307f3e333db8dd1c6b365b408a59b701d823bef9be774a59b3f44f64c9444e3bb0115c0c549cb00945385dab
DIST rdflib-6.0.1.tar.gz 1245483 BLAKE2B fd1c9837c25c8110bb44bd280803ec987ba865f8fea8187a1fca6173786deea65f462cf9f55f3c3c69d4fc18b01d37fc77b7b425e618c7b2e80324d7f5531f3e SHA512 d78c61a949a9c88297368820de386d289ef1722f5b2c4dad25a453c6bc9919fb98be23e682f739de6485f81746a1c338e4045c24ca058ed0b2848b81c0d34f52
+DIST rdflib-6.0.2.tar.gz 1273100 BLAKE2B aefd98c480710ece6fc5e621ebc0526eb24c61d36872280aa369baa2ce5bf90173190fa01d592861d2d6a9700fe9fc43a9ebe6d0b1f68851442e860ca702bf31 SHA512 0d14902d24582aad01289f5265feba3c533bbf5a0928b2e1032ba0af16d16cce46a92bde0f01ec2980351c1c13fe2cf4113445d2731e04400f0c20de73efa050
diff --git a/dev-python/rdflib/rdflib-6.0.2.ebuild b/dev-python/rdflib/rdflib-6.0.2.ebuild
new file mode 100644
index 000000000000..ee10e05cea5a
--- /dev/null
+++ b/dev-python/rdflib/rdflib-6.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="examples sqlite"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/berkeleydb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+python_prepare_all() {
+ # these tests require internet access
+ sed -e '/doctest/d' -i setup.cfg || die
+ rm test/{test_sparql_service.py,test_graph.py,jsonld/test_onedotone.py} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "support for sys-libs/db (Berkeley DB for MySQL)" dev-python/berkeleydb
+}