summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-25 20:19:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-25 21:58:10 +0200
commitb91bcfccbb2d0bd4a01d08eabbf95d610d3c6171 (patch)
tree6e51e1a8866663148db7558c3a95cedb1b78e5cd /dev-python/rapidfuzz
parentdev-python/cairocffi: Remove old (diff)
downloadgentoo-b91bcfccbb2d0bd4a01d08eabbf95d610d3c6171.tar.gz
gentoo-b91bcfccbb2d0bd4a01d08eabbf95d610d3c6171.tar.bz2
gentoo-b91bcfccbb2d0bd4a01d08eabbf95d610d3c6171.zip
dev-python/rapidfuzz: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.8.1.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index cf673de26af0..5389c840dbed 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,3 +1,2 @@
-DIST rapidfuzz-3.8.1.tar.gz 1592462 BLAKE2B 79062be1bdd2e5aa1c364f2426a8b3cb4fc03e44b7548e475abd60827821414ce4ebcbe90377c0d19eb2c8c741e2e171c73e4672fd8126bf99856ea095e9b85b SHA512 fbebdf804220841257075af51186cde5cf8b0ea71bc4ce208bc64853fd1b1aebf97bfb86d1db058c3fb72a60268e5297fe3691b042d52263c66f8da6ae37f90a
DIST rapidfuzz-3.9.0.tar.gz 1591028 BLAKE2B 84b8e4572a596c291d6579cfdffd0d624e00ca1f93a38337ba6ad543d346fea0b9a636cd3814724073588b3cd2e61dea9b8c0527b1630f8f06ea6593537bbde6 SHA512 bfd0d399dc75c6654d5e66522a057298d3914f8b74955e873034b314926127971f1bf4ddca0c2c92e81ba5bae79caf249303b169805d48ef3d6c64fb706c9547
DIST rapidfuzz-3.9.1.tar.gz 1595099 BLAKE2B 491eb1dd3ea64f361e15e6f828d162b383f2cbe068331c6001fb112966b599199870013bc2e10b5e8dfe1d7c6f676a6d577d9d43b6054874a3b721233d17ba77 SHA512 f8efcc271a823c957b2a00f78ab7bf37133a87027fcb75d9e24cf1629b776d3f970ebe4f596e6685013408637e2e2b3713680c7716e9adb505241b61decee18b
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.8.1.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.8.1.ebuild
deleted file mode 100644
index 1947e3941fcd..000000000000
--- a/dev-python/rapidfuzz/rapidfuzz-3.8.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
-HOMEPAGE="
- https://github.com/rapidfuzz/RapidFuzz/
- https://pypi.org/project/rapidfuzz/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# all these are header-only libraries
-DEPEND="
- >=dev-cpp/taskflow-3.0.0
- >=dev-cpp/rapidfuzz-cpp-3.0.4
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
- # remove bundled libraries
- rm -r extern || die
- # force recythonization
- find src -name '*.cxx' -delete || die
- # do not require exact taskflow version
- sed -i -e '/Taskflow/s:3\.3\.0::' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-
- export RAPIDFUZZ_BUILD_EXTENSION=1
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # scikit-build is broken and reuses the same build
- # https://github.com/scikit-build/scikit-build/issues/633
- rm -r _skbuild || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}