summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-06 23:34:24 +0000
committerSam James <sam@gentoo.org>2021-06-06 23:53:29 +0000
commit580696fb60bb6638b2b0f3c39b4443c521328811 (patch)
tree68262e09d9a218bceabb58afc40a56cbff6e1c67 /dev-python/radon
parentdev-python/radon: mark ALLARCHES (diff)
downloadgentoo-580696fb60bb6638b2b0f3c39b4443c521328811.tar.gz
gentoo-580696fb60bb6638b2b0f3c39b4443c521328811.tar.bz2
gentoo-580696fb60bb6638b2b0f3c39b4443c521328811.zip
dev-python/radon: drop 4.1.0, 4.5.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/radon')
-rw-r--r--dev-python/radon/Manifest2
-rw-r--r--dev-python/radon/radon-4.1.0.ebuild52
-rw-r--r--dev-python/radon/radon-4.5.1.ebuild26
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/radon/Manifest b/dev-python/radon/Manifest
index 162c11a01ad7..94cf26f77954 100644
--- a/dev-python/radon/Manifest
+++ b/dev-python/radon/Manifest
@@ -1,3 +1 @@
-DIST radon-4.1.0.tar.gz 3672016 BLAKE2B 3da02d62a2be0ab709bbb573372b86971f2eafd98724ea984236710c7f3e3517215bf496d621d42e9e93b747e3b8742f9cf156d3477c5c1cc4ac6098f0008b8f SHA512 c594fb2822a5311f1daf18304c601b4363477bee808f32a0eada6dd28560668a93cfa614196a614240eca436dea48945a29915bd4d347946aa28def0780bc93c
-DIST radon-4.5.1.tar.gz 1873194 BLAKE2B 3bbbfd1fcddb8c89c39240d7de082342b667c53a663e766dea16032ae5a7a1eca2a3a55664f39d0a60551db8c27e0f1102439409ee50520f8ffeb7ea20e5319b SHA512 8f27af1b9fed27806415f7af12f7480f638c71c741b3e7e150a0137964f48d43e615d410a84a8e093aaed28c92ad57f22e36e1d1a9819c335635ec175c4e8314
DIST radon-4.5.2.tar.gz 1873164 BLAKE2B 64a6def2be3505e247625b11deaaf75520781f98748cd8fec07c0d525905605deaf7f17c0103c6d41361ac0c6f62f489aeb418b5bd592dbd5b12755ec73e0116 SHA512 247fcd715ed3dfb889a73889fb5be8dc159673beb3abe1e1ba5170b8caadb85ad405ebd05f6a9080a6097f1c731b83b9dbe8b7f564f2a39b1b7cb0239f445813
diff --git a/dev-python/radon/radon-4.1.0.ebuild b/dev-python/radon/radon-4.1.0.ebuild
deleted file mode 100644
index a562a5b5d0fc..000000000000
--- a/dev-python/radon/radon-4.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Code Metrics in Python"
-HOMEPAGE="https://radon.readthedocs.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RCDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/flake8-polyfill[${PYTHON_USEDEP}]
- dev-python/mando[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
-"
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- ${CDEPEND}
- test? (
- ${RCDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- ${RCDEPEND}
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" radon/tests/run.py || die "tests failed to run under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/radon/radon-4.5.1.ebuild b/dev-python/radon/radon-4.5.1.ebuild
deleted file mode 100644
index fe5b81488746..000000000000
--- a/dev-python/radon/radon-4.5.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Code Metrics in Python"
-HOMEPAGE="https://radon.readthedocs.io/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/flake8-polyfill[${PYTHON_USEDEP}]
- dev-python/mando[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest