summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-05 15:28:01 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:28:01 -0800
commitbfc4909893cae1c52c4860c6b7a0acd41eccbc95 (patch)
treeaea03aeee4064693b959104ea8bfff5b3805f0b0 /dev-python/pyudev/pyudev-0.22.0.ebuild
parentdev-games/freecell-solver: python3_8 (diff)
downloadgentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.tar.gz
gentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.tar.bz2
gentoo-bfc4909893cae1c52c4860c6b7a0acd41eccbc95.zip
dev-python/pyudev-0.22.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyudev/pyudev-0.22.0.ebuild')
-rw-r--r--dev-python/pyudev/pyudev-0.22.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyudev/pyudev-0.22.0.ebuild b/dev-python/pyudev/pyudev-0.22.0.ebuild
new file mode 100644
index 000000000000..2fba5997b60f
--- /dev/null
+++ b/dev-python/pyudev/pyudev-0.22.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to libudev"
+HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="qt5"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/udev
+ qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGES.rst README.rst )
+
+#PATCHES=(
+# "${FILESDIR}/${PN}-0.19.0-skip-non-deterministic-test.patch"
+#)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
+ ewarn "change it to /var/tmp to ensure tests will pass."
+ fi
+
+ # tests are known to pass then fail on alternate runs
+ # tests: fix run_path
+ sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
+ tests/test_core.py || die
+
+ distutils-r1_python_prepare_all
+}