summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 21:57:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 22:05:09 +0100
commit22c7421e7b948831718b49dcad06c5ff55ecc645 (patch)
treedff8d289072b958c03f0b5f3b17f94de99d11cb4 /dev-python/python-utils/python-utils-2.6.0.ebuild
parentdev-libs/flatbuffers: Stabilize 2.0.0-r1 arm64, #829330 (diff)
downloadgentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.tar.gz
gentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.tar.bz2
gentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.zip
dev-python/python-utils: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils/python-utils-2.6.0.ebuild')
-rw-r--r--dev-python/python-utils/python-utils-2.6.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-utils/python-utils-2.6.0.ebuild b/dev-python/python-utils/python-utils-2.6.0.ebuild
new file mode 100644
index 000000000000..ae6983ffe562
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}